totalspaces2 is not working with yosemite, is it a hard work to fix it?

log: Wrong OS version, Mavericks needed

You were fast!

I cannot say yet. I will post back here as soon as I have had a chance to see what’s changed and how much work it is.

At this point I’m cautiously optimistic. It’s nothing like as big as the Mavericks changes.

Still too many unknowns to really estimate time, but I don’t think we’ll be without TS for too long.

1 Like

I have taken the plunge & am running Yosemite on my 2012 MacBook Air. The main reason is that something in Mavericks broke TotalFinder (see previous post) & just generally not impressed with Mavericks (it has been a long year ;))
I did manage to get it to load when I was running a bare bones install of Yosemite from an SD card but it would fail whenever I invoked the Visor function.
Now that I am running it on an almost full install i.e. extra Menu Bar items etc. it fails to launch.
Please do not interpret this as a complaint, I am merely trying to provide some data for troubleshooting.
Many thanks for your efforts so far.

Ok thanks. Antonin is working hard on TotalFinder for Yosemite.

Ping me if you need a beta tester for TS. I’ve just fired up Yosemite on a spare SSD for testing.

Thanks. At this point I have a functional version, but lacking multi screen support. I’ll get out a beta asap, likely to be over the weekend.

Never use the multiple-screen feature anyway, have yet to find a way to make it useful for me, given the way I use spaces…
Unfortunately, Spaces and thus TotalSpaces is so integral to the way I work, that it’s the single most urgent piece of software to get productive with Yosemite.
The other would be finally having a good replacement for Zevo (ZFS file system…), but that’s another story.
So any beta, prerelease is highly anticipated :slight_smile:

Please let me know if this works:

Dragging windows between monitors is a bit broken, but other than that it should work. It seems somewhat rough around the edges, but so is Yosemite at this point :smile:

If you notice anything that’s not working, please do let me know and I’ll do my best to fix it.

works well, but it seems that the ruby api is not work
currentspace = 1
2014-06-07 06:44:44.360 ruby[627:13519] +[NSScreen _screenForUUID:]: unrecognized selector sent to class 0x7fff789d92d0
2014-06-07 06:44:44.361 ruby[627:13519] *** Terminating app due to uncaught exception ‘NSInvalidArgumentException’, reason: ‘+[NSScreen _screenForUUID:]: unrecognized selector sent to class 0x7fff789d92d0’
*** First throw call stack:
0 CoreFoundation 0x00007fff93fc014c __exceptionPreprocess + 172
1 libobjc.A.dylib 0x00007fff960ab57d objc_exception_throw + 43
2 CoreFoundation 0x00007fff93fc2f7d +[NSObject(NSObject) doesNotRecognizeSelector:] + 205
3 CoreFoundation 0x00007fff93f0c604 forwarding + 1028
4 CoreFoundation 0x00007fff93f0c178 _CF_forwarding_prep_0 + 120
5 libtotalspaces2api.dylib 0x000000010e7a678f +[NSScreen(TSDisplayUUID) screenForUUID:] + 63
6 libtotalspaces2api.dylib 0x000000010e7a603e tsapi_windowList + 1582
7 libffi.dylib 0x00007fff95886f44 ffi_call_unix64 + 76
8 ??? 0x00007fff517daf40 0x0 + 140734560579392
libc++abi.dylib: terminating with uncaught exception of type NSException
Abort trap: 6

Thanks Stephen (and Antonin),

This release works fine for me on Yosemite. I don’t use the ruby API though.

Best regards,

Hi. I tried the 2.2.0 beta on 10.10.0. It worked fine on my 2010 MacBook Air. (I don’t use API or external monitors).

As an experiment, I tried it on 10.9.3 (I’m not sure if your intention is to have a multi-OS version binary). It let me install, but icons in the preferences were mostly missing and it wouldn’t show the overview grid. I don’t care about this, but thought I would mention it in case you do.

Thanks for the fast work!

Thanks @obscurebug - it will be both Mavericks and Yosemite compatible, but there are a few breaking changes just now. There will be an updated beta soon.


Version 2.2.1 and 2.0.3 of the TotalSpaces2 gem should work ok.

@obscurebug Version 2.2.1 should work ok on 10.9.x.

Hi @stephen,

I just installed 2.2.1 on a couple of 10.9.3 systems and a 10.10 system and it looks good to me. Achievement unlocked!


how to update gem 2.0.3

*** LOCAL GEMS ***

bigdecimal (1.2.0)
CFPropertyList (2.2.0)
ffi (1.9.3)
io-console (0.4.2)
json (1.7.7)
libxml-ruby (2.6.0)
minitest (4.3.2)
nokogiri (1.5.6)
psych (2.0.5)
rake (0.9.6)
rdoc (4.0.0)
sqlite3 (1.3.7)
test-unit (
totalspaces2 (2.0.2, 2.0.1, 2.0)
[root@ duoer]$ gem install totalspaces2
ERROR: Could not find a valid gem ‘totalspaces2’ (>= 0), here is why:
Unable to download data from - Errno::ETIMEDOUT: Operation timed out - connect(2) (
^CERROR: Interrupted
[root@ duoer]$ gem update totalspaces2
Updating installed gems
Nothing to update
[root@ duoer]$

Seems like there was a problem at rubygems.

Try this:

~ sds$ gem uninstall totalspaces2

Select gem to uninstall:

  1. totalspaces2-2.0.1
  2. totalspaces2-2.0.2
  3. totalspaces2-2.0.3
  4. All versions

Successfully uninstalled totalspaces2-2.0.1
Successfully uninstalled totalspaces2-2.0.2
Successfully uninstalled totalspaces2-2.0.3
~ sds$ gem install totalspaces2
Fetching: totalspaces2-2.0.3.gem (100%)
Successfully installed totalspaces2-2.0.3
Parsing documentation for totalspaces2-2.0.3
Installing ri documentation for totalspaces2-2.0.3
Done installing documentation for totalspaces2 after 0 seconds
1 gem installed
~ sds$

Oh thanks
but this can not work any way, so download it and install from local

Just tried 2.2.1 on Yosemite, works fine with my config (I only use TotalSpaces2 to remove Spaces transition). Thanks for the fast update.