TotalSpaces2 on Yosemite: hotkey alt-4 (only) doesn't work after reboot

I had to reboot the mac pro this morning. Before the reboot, Alt-4 worked on either of my dual display setup to go to the 4th desktop on either display (Desktop 4 on main display, Desktop 12 on secondary). Now it doesn’t work at all. All other Alt-n combinations work perfectly to go to the appropriate desktop.

I’ve looked in the TotalSpaces settings and Alt-4 is set as the shortcut for the 4th desktop on either display. I tried to reset it but Alt-4 is never seen when “recording”. There is no keyboard shortcut for Alt-4 that I can see in System Preferences.

What else to try?

Most odd - all I can think is that some other app must be intercepting Alt-4. Are there any possible culprits?

My first thought was TextExpander (I disabled it). Then BetterTouchTool (I disabled it). Same problem.

I’ll shutdown one app at a time and see if it starts working.

I have most of the same apps working on the mac pro and also the macbook air. It works fine on the macbook air. :frowning:

I started taking down apps I thought might interfere and tried Alt-4 after I brought each down. Bringing down each of these made no difference:

  • text expander
  • better touch tool
  • pop clip
  • clamxav

I was really grasping at straws when thinking clamxav would have anything to do with it.

Then I stopped TotalSpaces and restarted it. All was back to normal. Alt-4 worked fine. Then I brought up the previously shutdown apps and Alt-4 still works fine.

Thanks for doing the investigation - I really can’t explain this mysterious ALT-4 behaviour. Let me know if it happens again.