TotalSpaces2 status under macOS 10.13 (High Sierra)


#61

Hi there
Not so good here. What is the right procedure to update?
The very first thing I did (after installing high sierra) was to update from inside the application. So I clicked in ‘Check for updates’, it downloaded whatever update (It said 2.5.4, I think I remember) and complaint about the SIP thing. So, restarted, then I had to go to recovery to do the csrutil disable thing. Back into osx, it seemed to have installed ok.

But it’s not working. Not working means it does not transition to any space but, transitioning with default os x, the menubar icon shows the right number of the space though (I’m working with a 2x2 grid). Then, I’ve donwloaded the 2.6.12 version from the top of this thread and dropped into Applications folder, quit TS2, start again with same result.

Despite downloading the so 2.6.12 version, clicking in ‘About’ keeps saying version is 2.5.4, which I dunno whether or not is right. Also the Registration button keeps enable in About dialog, despite I’m a registered user (telekosmos, FYI :slight_smile:). That is not annoying at all, just, as before, I dunno whether or not is right.

Looking forward to hear you how to go on. Don’t hesitate if you need more info about it.

Cheers and great job!!


#62

Hey Stephen, I’m also having trouble with MacOS High Sierra. After installing HS, I uninstalled TS2 ver 2.54, rebooted computer to disable csrutil, and then proceeded to reinstall TS2 ver 2.54. After reinstalling I’m not able to use TS2 to switch between spaces and I can’t see the overview grid. When I do try to switch between spaces the space matrix graphic sometimes appears for a split second but then disappears and the space does not switch. Should we currently be using ver 2.54? Do you have any suggestions?


#63

Hi again, please disregard my last message. I used the version 2.6.12 and everything is working smoothly now. Thanks!


#64

Hi, all the update channels are now pointing to version 2.6.13, which is the latest.

If you run into problems, please uninstall using the uninstaller in the dmg, and then re-install.

If you still can’t make it work, let me know and I’ll try to figure it out.


#65

Hi again
Uninstalling/reinstalling procedure worked, and now it is displaying 2.6.13 version number when clicking the About option.

Thank you for the hint!!!


#66

Hi Stephen, I’ve installed 2.6.13 and generally things appear to be working as intended. However, I have noticed that the transitions/animations are much slower then they used to be. I always set transitions to the fastest speed so that movement between spaces is snappy. However, now the transitions and the animation to see the overview grid is much slower than before. I’m not sure if anyone else is experiencing this same issue. Would it be possible to speed up the max speed of transitions/animations?


#67

I haven’t changed those animations. I wonder if this is caused somehow by the new metal windows server in High Sierra.

I’ll see if there is anything to be done, but I don’t know if it’s solvable. What mac hardware do you have?


#68

Thanks for looking into this Stephen. I’m using a late 2016, 15 inch MacBook Pro with 2.9 Ghz Intel Core i7. I’m currently hooked up to an external monitor (LG 43UD79) but the animations slow if I’m hooked up to the external monitor and also when using the MacBook without the external monitor.


#69

Yeh, I’ve noticed that even with just the 2880x1800 LCD display it struggles with the animations a bit sometimes, it’s pushing a lot of pixels about. But of course modern GPUs should be up to the task.

It might be possible to rewrite those animations using metal, I’ll look into it, but this won’t happen quickly.


#70

I really hope you rewrite the animations in Metal 2. My Mac’s animations became silky smooth after upgrading to High Sierra, but Totalspaces 2 lags behind :frowning:


#73

Hi Stephen, could you check what’s going on with TS2 not working anymore with macOS 10.13.4 beta 3 (17E160e) ? We have another dedicated thread for this. Thank you in advance.


#74

Hi, yes, bear with me, I’ll look at it asap.