BinaryAge

TotalSpaces2 v2.3.6 loses hotkeys sometimes

If I do various things (like create or remove a fullscreen app, or unplug a monitor, or probably other things that are similar and change desktops around) then some or all of my hotkeys are lost (stop working).

I realise there are some similar bug reports but I think this particular case isn’t quite covered. I don’t have hotkeys enabled in the Keyboard shortcuts control panel under ‘mission control’ using only hotkeys in Total Spaces.

Also when a hotkey stops working I can’t (re)set it in the hotkey menu. It appears to still be getting ‘caught’ but not acted upon. Quitting TotalSpaces2 and restarting it fixes everything up fine. So that might be a hint as to how to fix the issue.

Cheers for the product, 2 days into the trial and I am thinking it will be invaluable for me.

1 Like

Hi, yeh we’ve normally seen something else competing for the hotkeys. But as you have checked that route I’m not sure what the problem is.

Which hotkeys are you using - which modifier key combinations? (So I can try to reproduce the issue.)

Sorry, never got around to coming back here. I was using option+1,2,3,4,esc.

I have worked around the issue by using the native macos shortcuts to map option+1,2,3,4 and then mapping my fullscreen space to option+esc within total spaces and removing all other shortcuts in total spaces. It seemed to be the numbered spaces losing their shortcuts as they change order etc.

I’ve not had any issuewith hotkeys since making the above change.

PS just bought a license. It’s worth it just to remove all the animations from mission control, and the all desktop expose is better than any built in expose.

I’m having the same issue since moving to a new Yosemite MacBook Pro. CTRL-2 no longer switches to desktop 2 on either display, and if I unset it, I can not Re-Set it. Yet it does nothing, and is not defined System Prefs > Keyboard > Shortcuts. I can even set it there and make it work for Mission Control Desktop 2, but it won’t switch display 2 as it doesn’t understand TotalSpaces’ desktops.

Does anyone know how to trackdown what might be “eating” a shortcut??? This is driving me crazy! Thanks.


Update: Tried the obvious: quit and restart TotalSpaces2, and now it’s fine. How and why ^2 would “break” is beyond me, but the restart is all that was necessary!

Hi, I think there are some rare circumstances where TotalSpaces would need a restart to recognize new shortcuts, but a restart should fix it in all cases, so good that that worked for you (and thanks for letting me know)

Stephen,

Confirming the intermittent loss of Hotkeys persists in v2.8.12 on MacOSX 10.15.6 Catalina with 2020 MacBook Pro 13.

My TotalSpaces2 configuration specifies hotkeys F1 - F6 to switch to Desktop 1 - 6.

My loss of hot keys happens during:

  • Plug or unplug a monitor or Undock from USB-C
  • Starting another application that binds the hotkeys (Idea IntelliJ, Scooter Software BeyondCompare)

My loss of hotkeys is partial:

  • I will only loose F2 and F4 when IntelliJ starts, for example. F1, F3, F5, F6 remain operational.

My solution is to kill TotalSpaces2 process then restart it. I do this approx 3 times / workday.

Future Ask:
I would enjoy a HotKey that would instruct the TotalSpaces2 process to re-bind all hotkeys.

Thanks for the great software! TotalSpaces2 is invaluable for my productivity and I recommend it often.

Sincerely, Taylor

I don’t know how IntelliJ manages to snatch the TS2 hotkeys such that they no longer work.

But ok, I think it’s not a bad idea for the hotkey. I have used Shift-control-option-command-space for some internal testing sometimes as probably nobody uses such a bizarre combination. Would that work?

Stephen, Thanks for the fast response! The bizarre combination would certainly work!

Three ideas:

  1. Following the ‘Principle of Least Surprise’, if you do have the time to update the Preferences… UI dialog, I would expect visibility for this feature to exist within the Hotkeys tab that currently houses: “Change Space”, “Move Current Window”, “Overview Grid”, etc. (Screenshot below)

  2. A simple implementation would be to add informational text that explains the hardcoded re-bind sequence. I see informational text in the Hotkey dialog today: “Hotkeys for each Space can be set in Layout”. I would expect the new message to be “Hotkeys can be re-bound at any time using Shift-control-option-command-space.”

  3. A complex implementation would be to enable the “Rebind Hotkeys” hotkey to be user defined, just like the others. Not necessary, but nice to have in case you don’t to loose your sequence for your own use in testing :slight_smile:

Hi from Charleston, SC! Have an awesome day! Taylor