TotalTerminal fails to start in El Capitan Public Beta

I have just installed Public Beta 3(build 15A234d) and it seems the rootless=0 workaround doesn’t work anymore… I fear Apple disabled that option. Can anybody else confirm? Maybe I just missed something.


It seems the rootless option has been removed from Public Beta 3, more information here:

i just upgraded to beta 3 and i still have rootless mode available and in use

weird, from what I read rootless has been removed from Public Beta 3 and indeed it’s not working for me anymore. However I managed to disable SIP entirely following the steps here:
I thought it would have been enough to disable SIP > Install Total Terminal > re-enable SIP, but it seems like Total Terminal’s injecting stuff at launch time, which requires SIP to stay disabled all the time. Not sure the Recovery Mode workaround is going to be a viable long-term solution.

Any updates on this? Still not working in public beta 6.

Just turn off the System Integrity Protection, then TotalTerminal can work well

And how do you turn off System Integrity Protection?

follow this:

If you want to let TotalTerminal works, you must keep SIP off.

Thank you, this works, I just hope apple fixes the way this is done so we don’t need to go to these extreme lengths and actually turn of a valid feature.
I’ve actually send them a feedback about this through the feedback assistant, so… :smile:

Yes, this configuration are just designed for developers. I hope the next version of TotalTerminal needn’t do this to make it work.

Upgraded to El Capitan to find that my most-used hotkey (⌥~ to bring up TotalTerminal’s Visor) doesn’t work anymore. Tried iTerm and it’s horrible. Outdated GUI style, doesn’t support basic hotkeys like ⌥↑→↓←, etc. Disabled SIP just to continue using TotalTerminal. Please keep the product running!

Dropped support is really a bad and sad news…

Since iTerm2 is not a perfect software and more of that, heavier than total terminal it’s too bad to have to switch on it… Keep continue searching a solution. I have another tweak wich not support El Capitan, but a fork have been done and the soft is running fine

I hope you’ll find the force to take back the developpement and bring us an updated version of TotalTerminal :slight_smile: :slight_smile: :slight_smile:
I really love this program an no other are so great (iTerm is a good program but miss lot of natural fonctionnality and have some bugs, example you cannot switch the visior from screen1 to screen2 without going in pref… totalterminal do this really simplier by following on wich screen the mouse are)

Ho i already said that but… TotalTerminal is really light and bring us everything we need :slight_smile:

Please keep your software alive

I have also suffered the consequences of upgrading to El Capitan, my beloved TotalTerminal has stopped working. Please keep supporting TT, the other options are not half as good and I need my quick access hotkeys working. PLZ keep supporting TT!!!

My Visor didn’t work anymore… I thought my life was over! Good thing that fix took!

$crsutil enable… blah blah blah. Disable the SIP. I don’t want to tell you hot to do it because you should make sure you understand what your turning off… but this is my work machine… I need this to dominate others! Where’s the donate button!

For anyone who is looking for an alternative, you can install iTerm, set the hotkey (cmd+` or the one that you prefer) customise all your settings to your needs and then apply this fix

Now it should work exactly as TotalTerminal :smile:

not really exactly…

Indeed, iTerm2’s UIX are far from what TotalTerminal’s was. I’m still looking for other alternatives though I hope the developers change their mind on pulling the plug on TotalTerminal.

Decided to go ahead and turn off SIP as well. Life is good again.

Think will do the same… xtrafinder and continuity activation tool need sip to be disabled too.

WOW I have been using Total Terminal since it was called Visor and have been loving it, unfortunately because it now requires me to disable SIP I might have to check out iTerm2 which totally sucks. I hope that the developers refactor the code behind Total Terminal so that disabling SIP is no longer required :frowning: