TotalTerminal fails to start in El Capitan Public Beta

Unfortunately, it looks like TotalTerminal no longer works in El Capitan:

7/10/15 12:38:40.780 PM Terminal[240]: TotalTerminal(546) System Policy: deny scripting-addition-send 'BATT'/'init'

I imagine this is the same issue that is affecting TotalFinder and TotalSpaces.

1 Like

I tried reinstalling, but it fails there.

The installation failed.
The Installer encountered an error that caused the installation to fail. Contact the software manufacturer for assistance.

TotalTerminal doesn’t have the warning banner that it won’t work in El Capitan like the other products do, and hasn’t been updated for a while…

I hope it will be fixed though - I’ve only had the pleasure of starting to use it very recently; it’s just so convenient having a small translucent window a keyboard-shortcut away.

Same for me, would love to see it fixed. Its hard to work without it.

This is interesting, because I’m also running El Capitan (latest beta) and it works for me just fine.

Visor functionality is stil working for you, @darwin? Not for me. I also get the error @rad_fax described.

I can confirm that it does not work at all for me.

I’d like to clarify that this is in the public beta (build 15A215h). I believe the developer beta is 1 or 2 builds ahead.

If I launch the TotalTerminal application, it launches Terminal but there is no menu bar icon. The visor feature does not work at all, and there is no TotalTerminal tab in Terminal preferences.

I tried reinstalling and get the same installation error.

@darwin are you running the public beta or the developer beta?

Same here, I truly hope there will be a build for El Capitan soon, I can’t live without TotalTerminal ;^)

Startup fails on:

… agent v1.5.4 started (TotalTerminal)
… requesting injection into[5494]

Having the same issue here. It worked great with b3 but fails to start with b4.

I can confirm as not working (for me) on El Capitan developer beta 4 - was also working great prior to that.

Ditto. Worked up through DP3, fails with the System Policy error logged on DP4.

I just disabled rootless (disable “System Integrity Protection”) and it functions again. Not a great long-term solution, but a workaround for now.

Yes, I can confirm as not working the latest developer beta 4 (10.11-15A226f) with System Integrity Protection enabled.

Our confusion with reports was caused by developer betas being slightly different than public betas. People running public beta were first to experience this change (even before developer betas).

I have personally switched to iTerm2. They offer Visor-like feature and it can be tweaked to behave similar to TotalTerminal (colors/keyborad shortcuts/etc.). There is probably no need to stick with TotalTerminal anymore. Thank you for using Visor/TotalTerminal over the years. It is time to switch.

iTerm2 is really bad, it’s sad that there is no walkaround for Total Terminal except turning off system integrity protection.

I have just installed Public Beta 3(build 15A234d) and it seems the rootless=0 workaround doesn’t work anymore… I fear Apple disabled that option. Can anybody else confirm? Maybe I just missed something.


It seems the rootless option has been removed from Public Beta 3, more information here:

i just upgraded to beta 3 and i still have rootless mode available and in use

weird, from what I read rootless has been removed from Public Beta 3 and indeed it’s not working for me anymore. However I managed to disable SIP entirely following the steps here:
I thought it would have been enough to disable SIP > Install Total Terminal > re-enable SIP, but it seems like Total Terminal’s injecting stuff at launch time, which requires SIP to stay disabled all the time. Not sure the Recovery Mode workaround is going to be a viable long-term solution.

Any updates on this? Still not working in public beta 6.

Just turn off the System Integrity Protection, then TotalTerminal can work well

And how do you turn off System Integrity Protection?