TotalTerminal not loading on startup in Mavericks

Hi all. Since I upgraded to Mavericks, TotalTerminal has not been loading on startup. Instead, I get a dialog popping up that says “AppleEvent timed out”. To get TT working, I have to run Terminal then run TT and wait a while. I’ve tried reinstalling TT, with no luck.

Any help much appreciated.

I’m having the same issue on Mavericks (using the current TotalTerminal version, 1.4.4)

Unfortunately I have no good solution for you right now. This was also happening to some TotalFinder users and I had to rewrite launching script into ObjectiveC helper app. It resolved most of the issues.

I’m going to do similar thing for TotalTerminal eventually. But it has not priority right now. Please try to experiment with adding/removing items from your login startup items, or change delay in the script.

Same issue here. Extremely annoying

What worked for me was to run the installer for TotalTerminal after a reboot. It works, but it’s annoying.

I have re-evaluated this issue and I will fix it in 1.4.5. I will use the same code I have used in TotalFinder which fixed similar problems for majority of TotalFinder users. Stay tuned.

I got it working again by increasing the delay in the script to 5. It might work with lower numbers but I didn’t try since this worked for me first time.

These issues should be fixed in 1.4.5:

Please test it and report back.

It’s not working for me. TT isn’t loading on startup at all and, although I don’t get the timeout error, I have to load Terminal first and then TT, in order to get it to work. The pity is that I had got the previous version working.

Do you have in your login startup items? Is it really coming with 1.4.5 release? In you you should see something like:

11/2/13 12:40:41.659 PM Terminal[1800]: TotalTerminalInjector v1.4.5 received init event

[quote=“darwin, post:10, topic:684”]
Do you have in your login startup items?[/quote]



I do see that, but presumably it logs that if you run TT manually, no? Here’s what gets logged:

I’ll try another clean install and see if it works.

The clean install did it - it’s loading on startup, as it’s supposed to now. Thanks for making TotalTerminal compatible with Mavs so quickly!

1 Like

I’m getting the same issue, but I’m seeing the following in

11/4/2013 13:02:50.086 Terminal[858]: AppleEvents/sandbox: Returning errAEPrivilegeError/-10004 and denying dispatch of event BATT/init from process 'TotalTerminal'/0x0-0x2d02d, pid=356, because it is not entitled to send an AppleEvent to this process.

@pnomolos Please make sure your is in /Applications and not in ~/Applications, also look into ~/Library/ScriptingAdditons there should be no trace of TotalTerminal.osax. I assume you might have installed some historic versions and moved them around. This applescript error usually happens when apps from user folder try to talk to system apps in system directories.

1 Like

The TotalTerminal.osax scripting addition that was hanging about is what was causing the issue, thanks for the fix!