TotalTerminal stopped working MAVERICKS after Security Update

Hey there!

I recently performed an update on my computer (running OSX 10.9.5). The following 3 things were updated:

  • Security Update 2016-002
  • Safari 9.1
  • Remote Desktop Client Update 3.8.5

Upon the reboot, I saw that TotalTerminal did not launch. I tried launching it manually – no beans. I restarted again – still no beans.

Well I’m wondering if the new El Capitan security feature has also been included in the security update for Mavericks. But my XtraFinder (i’m no longer using TotalFinder) is still working fine.

iTerm has its own bugs – I would like to stick with TotalTerminal :]

Thank you!!!

I’m sorry. I cannot investigate this.

Have you looked into if there are any messages related to TotalTerminal?

As @darwin suggested, let’s see if there’s more information about this issue in the Console: output:

4/12/16 11:05:52.675 PM TotalTerminal[687]: Terminal is not running. Launching it... (/Applications/Utilities/
4/12/16 11:05:52.943 PM login[6941]: USER_PROCESS: 6941 ttys000
4/12/16 11:05:52.977 PM login[6943]: USER_PROCESS: 6943 ttys001
4/12/16 11:05:53.026 PM login[6950]: USER_PROCESS: 6950 ttys002
4/12/16 11:05:54.683 PM TotalTerminal[687]: requesting injection into[6939]
4/12/16 11:05:54.683 PM TotalTerminal[418]: requesting injection into[6939]
4/12/16 11:05:54.857 PM TotalTerminal[687]: TotalTerminal files have been modified since installation (the shell is corrupted)
4/12/16 11:05:54.858 PM TotalTerminal[418]: TotalTerminal files have been modified since installation (the shell is corrupted)
4/12/16 11:06:03.978 PM login[6950]: DEAD_PROCESS: 6950 ttys002

Nothing is logged when I click my global shortcut hotkey. Also, I cannot access TotalTerminal settings (that’s integrated in the regular Terminal Preferences, right?)

Thanks guys. I’m happy to supply you with any info you need.

I deleted the application and the (empty) folder ~/Library/Application Support/TotalTerminal. Then installed the latest version of TotalTerminal. Working again now. YAY!

That “shell is corrupted” message is caused by invalid signature of the TotalTerminal.bundle. For some reason system didn’t validate the code signature properly. Not sure what went wrong.