"Troubles launching TotalFinder" message after reboot

  • TotalFinder 1.11.3
  • macOS 10.14 Mojave

Hello, whenever I reboot, I always get the following message appear in the top right hand corner of the screen.


Once the machine has properly started TotalFinder seems to run okay, and I suspect this is just a timing issue when different processes are starting, so it isn’t really urgent. All the same, I’d rather it didn’t happen at all!

Any ideas?

1 Like

I have the same problem. I changes with backup from time machine from 2015 to 2018 macbook pro. Both with Mojave.

Could you both please try to run the uninstaller and then install TotalFinder.app again?
I suspect that you have some old TotalFinder.osax lying around.


If I uninstall and then reinstall, will my product still be registered okay?

Yes. TotalFinder does not remove the plist with licensing info:

I carried out the uninstall followed by the reinstall of 1.11.3, and I get the same error message when I reboot. It doesn’t matter too much, as I say, because the application works perfectly once the system has properly settled down.

There is one more thing you could try. In Terminal.app, you can tweak TotalFinder Agent’s plist:

cp /Applications/TotalFinder.app/Contents/Info.plist ~/.totalfinder-agent.plist
defaults write ~/.totalfinder-agent.plist HardInjectionDelay -float 10.0
killall TotalFinder
osascript -e "tell application \"Finder\" to quit"

Now you can launch /Applications/TotalFinder.app again. It should wait 10 seconds before injecting TotalFinder into Finder. This could help during startup. Maybe try to tweak that number to lowest possible before you start seeing the issue.

I tried carrying out the steps you suggested but the problem is still occurring. Does it need an even longer delay than 10 seconds, I wonder?

I had the problem too. I discovered in system preferences > users & groups > login items there was more than one copy of TF trying to load at once. Removing the extra copies resolved the problem for me.

1 Like

Hello, just to say that I’m having the same issue. Everything else works really well, thank you. :slight_smile:

That’s what I tried, really it was more running. Now only one TF starts at boot, but it does not help, it indicates an error. “Troubles launching TotalFinder” etc.
Other idea? This is only after Mojave’s up-grade … :frowning:

I get the same issue every time I try to start TotalFinder after upgrading to Mojave on my mid-2015 MBPr.

Note that TotalFinder works perfectly on my mid-2014 MBPr after upgrading to Mojave.

EDIT 5 minutes later:
I found the solution here:

sudo tccutil reset AppleEvents
osascript -e "tell application \"Finder\" to «event BATFinit»"