BinaryAge

Uninstaller won't open

#1

Whenever I try to open the uninstaller to uninstall asepsis it tells me that it can’t be opened because it is from an unidentified developer. I’ve already tried to uninstall it from the Terminal.app but that didn’t work either.

#2

I have the same problem. Had forgotten that Asepsis was installed so I upgraded from Lion to Mavericks. Instruction at the Panic Mode tab does not work.

It says:
Wrapper framework seems not to be installed (/Systems/Library/PrivateFrameworks/DesktopServicesPriv.framework/Versions/A_ does not exist)

I hope that helps.

#3

Using search of Finder it picked up two files moved into a folder called “Incompatible Software”

The files are
“asepsisd”
“com.binaryage.asepsis.daemon.plist”

Are those the files that need to be deleted?

#4

@Sven_Lauch this is strange. Mavericks installer should wipe-out asepsis wrapper and the system should work normally. I have to test upgrading on my machine, but I doubt upgrade would break the machine.

As of your question. Yes, feel free to delete asepsis related files in Incompatible Software

#5

Please look into System Preferences -> Security & Privacy -> General.

You should temporarily switch to “Allow applications downloaded from anywhere”. Asepsis uninstaller is probably not signed by BinaryAge signature.

#6

That worked! I was able to uninstall it. Thank you!

#7

Yes, it worked for me too. Thanks

#8

I have the same issue as Sven, where asepsis ended up in the /Incompatible Software folder.
Trying to run the command line uninstall script also does not work (asepsisctl: command not found). Is deleting the two files in /Incompatible Software all that is required to completely remove asepsis from Mavericks?
When will a Mavericks compatible version be available?

#9

Hi TJ,
just look at Dawin’s post above.

You have to change a security setting first before the script works. Afterwards you change the setting back.

#10

I have that option to allow all applications on all the time, so that’s not it. It appears as though Mavericks in addition to relocated the mentioned asepsis executable to the Unsupported Applications folder it probably removed any link/reference to asepsis from the /bin directories, so it simply can’t find it (the executable’s name ends with “d” like a daemon, but the command has no “d”, not really sure how it’s done)