BinaryAge

Upgrade to Mavericks 10.9.3 breaks Asepsis

#1

Seems (at least for me) that the upgrade to latest Mavericks (10.9.3) breaks Asepsis. The fix described on http://asepsis.binaryage.com/#diagnose does the trick (reinstall DesktopServicesPriv wrapper) but this is not something I have had to do on previous upgrades. I have had the same result on my iMac and MacBookAir

#2

Yes, it depends if Apple decides to replace the binary during the update. In case they don’t, Asepsis should work without reinstalling the wrapper. In case they do, you have to run the command to wrap the new binary. Asepsis diagnose check should let you know about it. I’m sorry I don’t have a better solution for this.

#3

The issues should be resolved in 1.4.1:

Postmortem:

1 Like