Visor problem on boot

I am having trouble with the Visor activation on booting my Mac. I have had this problem since 1.6.10, when running under Yosemite. The visor does work - but only if I bring up the TotalFinder preferences, and turn Visor off then on again. From here, I have no more problems till the next boot. I have tried uninstalling TF, as well as going through my mac’s OS digging out every instance of TF in Application Support, Preferences etc, rebooting and trying a reinstall. I have also removed all programs from my Login section in Users & Groups/Login Items and rebooting: no difference. This problem has persisted through each subsequent release of TF - and even through fresh installs of the OS.

I’m having this problem too! Came on here hoping to find a solution.

Ah - glad it’s not just me then…

oh great - also thought it’s only my problem …
any solutions so far?

thx harry

Would love a solution to this. It seems to me that once I get Terminal to show itself, then it works. So I have TT in my startup items, and I see it open in the Dock, but when I hit my command combination, it does not appear. If I click TT in the Dock, then a Terminal window appears and disappears; after that, it works fine.

I’m wondering if it has something to do with apps reopening on login?

This thread is about TotalFinder’s Visor. Not TotalTerminal.

Guys, can you please test 1.6.15 beta? I have reimplemented whole settings system which was originally based on NSUserDefaults shared with Finder. It might fix the visor issue.

Sorry…still mentally call Total Terminal “Visor”; did not see the tag.

I tried a few things; but no changes I’m afraid. I uninstalled TF 1.6.14, and removed its two .plists, as well as the one for the Finder itself. I also removed all startup programs from Login Items, then ran Disk Utilities. I installed 1.6.15 after rebooting the computer, and filled in my settings. My registration details only took hold on a second reboot, but the Visor issue remains - I have to toggle the Visor off then back on again to get it working, which it does till the next boot. If there are any logs and such I can send you, I’ll be happy to help out.

Yeah no change for me either.

Ah, bad luck. So the problem is somewhere in my other code.

@Donut4000 Thanks a lot for the help offer. I’m going to build a version with extensive logging and hopefully I will be able to diagnose it from the logs. Will ping you privately.

1 Like

I’m glad to announce I was able to fix the bug in 1.6.16:

The problem was introduced back in 1.6.5 when I did quite large reorganisation and broke one code path when hotkeys should be registered.

My apologies to all Visor users for all the pain.

Brilliant! Bug squashed, as Visor now works perfectly after a reboot again.

Thanks for all your efforts - it’s very much apreciated.


1 Like

Awesome!!! Thank you for fixing this issue so quickly!!! Amazing. Thank you thank you thank you!

I’m still having problems on Yosemite with the latest update… Show Visor is greyed in the menu bar and no matter which shortcut I set, it’s always gray and unreachable, any ideas?

I’m still having troubles as well. The visor does not work for me at all since upgrading to Yosemite, even with the newest version of TF.

Edit: I just reinstalled TF and it works now

Let’s continue this discussion here: