Visor-Window shows when clicking on Finder-Dock-Icon


#1

Hi,

when I dont have any window open and click on the Finder-Dock-Icon, the visor window shows up. I would prefer to open a window instead or at least that I can choose this in the settings. :blush:

Also when they are windows minimized, the visor shows up instead of the minimized windows.

For me, the visor should only come up, wenn I have pressed the shortcut.

Like I said, the best way would be to choose this in the settings, because maybe some other persons like it the way it is.

Greets


#2

This thread is related, I’ve implemented current behaviour because of that:

I’m working on a tweak which will enable the behaviour you have just described.


#3

Ah nice, thx!


#4

Upcoming version 1.6.2 will have a hidden tweak, which will do what you want:

defaults write com.apple.finder TotalFinderDockIconIgnoresVisor -bool yes

Finder restart is needed. To return the default behaviour:

defaults write com.apple.finder TotalFinderDockIconIgnoresVisor -bool no

#5

TotalFinder 1.6.2 beta is out:
http://totalfinder.binaryage.com/beta-changes#1.6.2


#6

Nice, thank you very much!


#7

+1

Can’t wait for 1.6.2 - though I prefer to shy away from a beta version at the moment.


#8

Thanks for this tweak, very useful.

One issue remains though with this tweak, when I use the Visor, pressing cmd+T to open a new tab will open a new tab in a new “classic” TotalFinder window instead of in the Visor. Same behavior for the new tab icon in the Visor.
So basically, tabs won’t work in the Visor.

Any idea?


#9

This was helpful, as I’m not using Visor feature. IMHO, this should be default behavior if Visor is disabled. Also, why don’t you add it to the options panel?