Waaaaaay too slow

I want to like this … but it’s soo much slower than Finder.
Switching tabs, opening windows, very annoying.

Same here. TF 1.6.17 in Yosemite 10.10.1.

I really see it’s much slower to navigate through folders and files than Finder. And I do very easy tests, just perform the same actions and navigate through the same folders with and without TotalFinder. The difference is very recognizable!

On the other hand, there are some features of TotalFinder, specially the “Folders on top” and “Automatically adjust widths” that I simply couldn’t live without.

So I hope next versions of TF fix this slowness :frowning:

1 Like

I wrote to support, and here’s what they said:

Well, this should not be a general problem. Others are quite happy.

I don’t know how to diagnose the issue and help you at this point. I’m sorry.


Is support mail address support@binaryage.com?

I’ll be happy to help to diagnose what’s wrong with it…


Yes, support@binaryage.com

I’m here. Are those folders on network drives? How many files are there? How big files? What is the folder structure? What are your Finder settings?

Maybe you could try to disable individual TotalFinder plugins to pinpoint the problem:

Thanks for your help.

For me it the most basic tasks that are slow, specifically:

  • switching from one window to another with <command><backtick>
  • switching tabs with <ctrl><tab>
  • opening a new tab with <command><t>

These are all nearly instantaneous in Finder.
With TotalFinder much much slower.

Which plugin(s) should I try disabling?

Note: It did become somewhat faster after restart Finder, restart TF, but still not anywhere as fast as Finder

So? Any ideas?

I have a similar problem after installing Parallels. Once have made a mistake, but I forgot and again installed Parallels instead of Bootcamp. Probably will have to reinstall Yosemite. Maybe it’s just a coincidence, but …

Hello? Anyone?

I’ve notice the same thing the past 2 months or so. I’ve been using totalfinder for years and never had a blocking issue like this before. It often takes the cpu over 100% bringing my (2014) Macbook Pro completely to it’s knees!
The parallels thing is interesting… I did install parallels a while ago as well… I don’t remember if that’s when the issues with totalfinder started though…

Perhaps the developer could test this as well?

Same problem here. Sometimes it’s that bad I just quit TF in order to keep things rolling. I do not have Parallels installed. I’m using the latest version of both MacOS and TotalFinder.

The strange thing is I got 2 computers with the same versions of OS X (10.11) and Total Finder. One works just fine, another struggles with TF being too slow (switching between tabs, even opening folders) unless I restart it. But the effect lasts few days at the most. :disappointed:

What I can say? Just my usual question. Anything strange going on in the Console.app -> All Messages of the slow machine? What about memory footprint of the slow Finder.app (with TotalFinder).

Hello there,

first, love this utility!

I’m also having slow folder switching. I noticed that it was come since version 1.7.11. Just tested it twice.

El Capitan 10.11.3 (15D21)

Watch my videos to see how new and old versions works.


I can confirm that the problem does not exist in 1.7.10 (currently available via brew cask). It exists in 1.7.12.

In addition, this is caused by the “Arrange folders on top” option. If you deselect this option, TotalFinder is no longer slow, because it is not spending too much time arranging folders. All actions are now smooth.

I have not yet bought TotalFinder. I am evaluating it precisely because I desperately need the “Arrange folders on top” feature in El Capitan. If this is not fixed in a future update, I am sorry but I will not buy TotalFinder, as it does not fit my purpose and brings Finder itself to a crawl.

I hope this can get fixed. You’ve got a new license (probably 3) if you manage to fix this.

Thank you very much

Thank you for detailed tests.

I know exactly what is causing that. But solution won’t be easy without reverting my recent changes.

The slowdown was introduced due to my attempt to resolve the sorting issue:

Please stick with v1.7.10 for now and I will try to find a way how to fix this.


I know it takes a while, and you are probably busy with other things as well, but I was wondering if you have managed to fix this bug already?

I ask because I’m nearing the end of my trial and, as I mentioned, this is a deal-breaker for me. I know the bug came because you fixed the occasional crash in column view (which I often have, since I’m in the previous version).

Thanks for any update

any idea when the fix will be released?

please try:

it is our latest testing version (not yet released)