Weird behavior on using Finder folder shotcuts

I have a few keyboard shortcuts set up to run a script that opens folders in the current finder window through the following AppleScript:

tell application "Finder"
     set target of Finder window 1 to folder "Macintosh HD:Users:David:Downloads:Dropbox"
end tell

This script worked flawlessly until Mavericks. Now my windows open and a weird grey bar appears, and the folder is displaced downward in the window. I’ve attached a screenshot. Furthermore, the mouse clicks are misalligned, so that if for example I tried to click the Photos folder in the attached screenshot, it would select the Public folder instead.

This behavior and weird bar go away if I open folder, go up a folder in the tree, or change finder views (this only seems to be a problem when opening folders in the list view).

I’m guessing this has something to do with Maverick’s built-in tab bar getting in the way?

Good news: I was able to reproduce it with your script. Looking into it…

This will be fixed in next release (1.5.25). Thank you for reporting.

Fantastic, thanks so much!