Whenever I open finder it will display in any space I go to. I only want it to display in the space I opened it in. I also use Total Finder


#1

Whenever I open finder it will display in any space I go to. I only want it to display in the space I opened it in. I also use Total Finder


#2

Perhaps Finder is assigned to all desktops? Please check in app preferences in TotalSpaces preferences.


#3

It is, but if I assign it to none then no desktop icons appear in any space, just blank wallpaper. If I assign it to any single space only that space will show the desktop icons. I might be crazy but I don’t believe I have ever seen this behavior before.


#4

I’ve not seen that either - you haven’t by any chance changed the com.apple.finder CreateDesktop setting?

Info here: https://gist.github.com/drdrang/7f31cd032609e5e7657588ecfae91644


#5

Thanks Stephen,

That was it. I have no idea how that got turned off. I vaguely remember running across that in the past and even had some notes on it in a file where I keep tips. all seems well now.