Where to by a license for Total Spaces 3?

I tried to buy a license for TS 3 from within the App with no success. It only shows a spinning wheel. Can somebody tell me where I can buy a license for Total Spaces 3?

Thank you.
Mike

Doesn’t anyone have any ideas? There are only a few days left, then the trial version will not start. Unfortunately I don’t get an answer from support@binaryage.com either.

Mike

Binaryage is trying it’s hardest to kill off customers i think.

But that would not make sense. TS3 is or was still in development. If binaryage had given up on further development, wouldn’t it have been fair to release the latest version of the app to everyone for free? Instead, I now have an app that runs to my satisfaction on Monterey, but whose trial period only runs for a few more days, and then I can no longer use it. I just don’t get it. No one responds to mails either. I confess that I am very disappointed. And frustrated.

We did get a report that the licensing was not working.
We are giving it away such as it is (alpha) with this coupon code: 7997B7C2 (this is a 100% free coupon to use in checkout not a licence code).
If that doesn’t work then we can try to figure out why.

@stephen I just tried using this coupon but it’s expired.

Sorry, so it was. Fixed, please try again.

@stephen Not for me. I still see the spinning wheel in a blank white window when I try to purchase a license.

Works for me now, thank you.

It worked for me, too. :+1: :slightly_smiling_face:

Hello, I’m trying to buy a license, or using the coupon code if still a possibility, but I can’t reach the buying page from the app. Spinning wheel spinning forever.
Is there any other way?

@wrein Same here. How can it be that a purchase is not possible with us, but it is possible with @nambrosch and @rjmorita? Geoblocking?

It can be an anwser, I have no idea what kind of infrastructure they use and because it is inside the app it’s not easy to find the back-end server it is calling, I’ve got some more details tracking the calls via my firewall app. The only thing it calls for is a CSS via a CDN. And I suppose it is the spinning wheel animation. It does not make any other call. So I can’t say it is blocked or limited.

I’ve got another call, but I think it’s polling to the version via sparkle to retrieve the most recent version downloadable. TotalSpaces3 Changelog

Mysterious. As for geoblocking, if that’s what it is, I am from Germany. Via VPN I have tried various attempts with IP addresses of other countries. All without success.

They use paddle.com as a platform for payment, but I don’t think there’s an easy way to reach the payment platform outside the app.
Today I’ve got this

"{"success":true,"response":{"customer_country":"IT","products":[{"product_id":638376,"product_title":"TotalSpaces3","currency":"USD","vendor_set_prices_included_tax":true,"price":{"gross":15.0,"net":12.3,"tax":2.7},"list_price":{"gross":15.0,"net":12.3,"tax":2.7},"applied_coupon":[]}]}}"

Somehow the api call answer with the product data, prices and tax… so it is responding, we’re not blocked As you can see it correctly discover my country, I’m in fact in Italy. I think it’s something in the app. Maybe it is stuck waiting or something is still missing.
Obviously I’ve tried turning off all the firewalls.

WAIT WAIT
I have misinterpreted the flow about hat JSON data I’ve received: I’ve it received by using the call tracked by the firewall directly in my browser. Maybe the app itself wasn’t able to receive it.
The good news is I think we can exclude geoblocking.

Impressive how you figured that out. Another idea just occurred to me: Is it perhaps due to the CPU platform? I use an Intel iMac. I know that TS3 in version 0.8.114 ran exclusively on Apple Silicon. The current one (0.9.125) runs fine on Intel as well. If @stephen took the payment routine 1:1 from the previous version and it requires a Silicon CPU (for whatever reason) it would definitely not work on Intel. Sounds a bit adventurous to me too, but I’m not a programmer.

I’m on an Intel Mac too, so it can be… Maybe the library they are using are only for Apple Silicon. but I think in that case it should return some kind of error… Wait you gave me an idea, so I took a look at the console right now and there are many crash report.
It crashes often indeed, but randomly and not at the same time of a buying procedure click, so no, I can’t figure a correlation with the eternal spinning wheel and the crashes.

I just purchased using the coupon code on an intel macbook pro.

Thanks @nambrosch … I’ve just tried and it worked for me too!

@mike33 try ASAP. Something changed… I suspect a Divine Intervention (@stephen). :innocent::innocent::innocent: