BinaryAge

Window to install system component NEVER appears


#1

Hi!

I am trying to install TotalFinder on my MacBook Pro (15-inch, 2017), 10.13.3 and is just impossible. I never get the pop-up window to install the system component. I have already tried 10 times enabling and disabling SIP but it doesn’t work. TotalFinder still works with SIP disabled, but I want to enable it!

I followed correctly all steps, since I also installed TotalFinder on my MacBook Air and it worked. What can I do? How can I force my computer to install the component?

Kind regards,


#2

Hi, there is a checkbox to silence those dialogs. And when one does, there is no easy way to bring them back. Except for tweaking some plist settings.

Easiest way will be to trash whole plist of TotalFinder.app (agent)

  1. Please force-quit TotalFinder.app via CMD+OPT+ESC
  2. In Terminal.app execute
rm ~/Library/Preferences/com.binaryage.totalfinder.agent.plist
  1. Launch /Applications/TotalFinder.app

This should do the job I believe. You effectively reset TotalFinder agent into factory defaults. I’m just not sure about system caching of plist files. Anyways let me know if it didn’t work. I will figure out a reliable way by tweaking individual plist keys responsible for silencing the dialogs.


#3

Hi!

Thank you for your quick help. It works now, but the solution was different and unexpected, and you may find it interesting:

I changed my system language (Spanish to English) in order to work better with TerminalApp and, after rebooting the system to apply the language preferences, the pop-up window to install the component magically appeared…

Thank you anyway!

Manu


#4

Oh, thanks. This would hint to a bug in my code. Maybe the dialog fails to load when non-english language is selected. I’m going to investigate it.


#5

Well, I was unable to reproduce it here on my system. Tried switching both to Spanish and Czech launguages and TotalFinder.app works as expected by offering the same (english) dialog.

ProductName: Mac OS X
ProductVersion: 10.13.4
BuildVersion: 17E197a