Blank spaces in Overview Grid jump to space with Path Finder. Yosemite

I’m using TotalSpaces2 2.2.9, Yosemite 10.10.1, and Path Finder 6.0.10 (1290). I set up different backgrounds and names for all 9 [Total]spaces in a 3x3 grid. One external monitor that’s mirrored to the MBPro laptop.

When I launch Path Finder 6.0.10 (1290), it causes problems navigating TotalSpaces2 that I did not have with the previous version of TotalSpaces (might be ver 1.2.9) under Mountain Lion.

When I slide the mouse into a hotcorner to display the Overview Grid, and I click on ANY empty space, that space is briefly displayed, then it jumps to Space #4 (the space with Path Finder).

If I open the Overview Grid again, and move any window into an empty space, and click on the now-non-empty space, TotalSpaces stays there (like it should).

If I again open Overview Grid and remove the only window in a space (by moving
it elsewhere), then click in the now-empty space, TotalSpaces2 stays there–just once.

If I open Overview Grid again and either:
(1) click back on the same empty space where I am now or
(2) click on another space, then back to the newly-emptied space, it jumps to Space #4 (the one with Path Finder).

If I exit Path Finder, this strange behavior in TotalSpaces stops, so it appears that Path Finder is somehow the culprit. I have also contacted CocoaTech ( about this.

I read luuk’s posting from May 2014, and I followed the Terminal commands:

  1. defaults write workspaces-auto-swoosh -boolean NO
  2. killall Dock

That fixed the problem with Path Finder’s interference. Now TotalSpaces2 will stay on a blank space selected from the Overview Grid.

Still, it’s odd that OS X thought Path Finder was doing something that required its attention (and auto-swooshing there). I agree with luuk that this should be an option within TotalSpace2.


An empty space does normally have Finder as the default app, and presumably path finder takes this role.

For various reasons I have been trying to find a way to prevent apps demanding attention like this, without having to disable the auto-swoosh feature. It is difficult to distinguish between unwanted space changes and wanted ones, for instance from clicking on the dock and using cmd-tab. But I hope to be able to solve this at some point.

Aha. That explains it, Stephen. I find it especially annoying when, for example, I’m typing something in, and in mid-word, OS X swooshes me over to some other app that’s demanding attention–like a two-year-old vying for my attention.

Unfortunately, when I disabled the Auto-Swoosh, it disabled Command-Tab (App switching). :open_mouth: I can see the different apps, and choose one, but it never goes there. So I think I’ll re-enable it and live with the occasional annoyance. And never leave a window empty.