Microsoft Word / Exce / PowerPointl (2011) not changing spaces properly


#1

I am trying to use the move current window hotkeys with Microsoft Word/Excel/PowerPoint (2011) but for some reason the window doesn’t get pulled when switching spaces. It works fine with other applications just not the Office applications. Has anyone else reported this?


#2

I just tried it with excel, document windows seem to work ok to me.

The splash window when is special, that won’t move.

Any specific steps to reproduce the problem?


#3

For the record, it seems this is connected to the EndNote (ms word) plugin.


#4

Hi - I am having the same issue - any solutions available? thanks


#5

Hi I’m having the same issue. When I move any Office window to a new space using TotalSpaces, it will very frequently glitch and launch me back into the empty space while keeping the window I want to use in the new space. The same thing happens when I try to navigate to another PowerPoint window in another space, it will throw me back into another open one.
It doesn’t happen if I use Mission Control to switch spaces with these applications. It only ever happens with TotalSpaces. I use Office every day for school. This issue is super frustrating and makes me not want to use TotalSpaces anymore.


#6

Hi,

The original poster was able to avert the problem by not using EndNote.

I have not been able to reproduce the issue so far, but if I can reproduce it then I can work on a fix. How are you moving the windows - by using the overview grid? Thanks.


#7

Hi Stephen,

I thought the problem was caused by Endnote but now I’m having the same problem without using EndNote. Must be something else.

Kevin


#8

I’ve had this problem even on my computer that doesn’t have EndNote. I’m not sure EndNote is the issue here, but even if it is, not using EndNote is not a very good solution to the problem. Regardless, I don’t think that’s the root issue here.

I change spaces by going into the overview grid, then dragging the window I want into another space, then going into that space. The space will then instantly transition back to the first space I had my window in. The menubar shows the Office app (not a finder window or anything else that might be open in that space); going through Window > DocumentName doesn’t work either, as it seems to think that document is the active window.


#9

Thanks, I’ll see if I can reproduce it.


#10

I have a screen recording of the glitch. I can send you that of post a link to it if that helps.


#11

That might be helpful - I can’t seem to be able to reproduce this at the moment - moving windows works normally for me at the moment.


#12

No problem. Here are two examples of what both of my computers do with office apps and TotalSpaces. PowerPoint is the most consistent with this on my computer, but I’ve had it happen with all of my Office apps.

I have the grid overlay as my bottom left hot corner. I changed spaces using TotalSpaces as well as Mission Control, to illustrate that it’s a TotalSpaces problem and not an Office problem.

Example 1

Example 2

Hope that helps. This is fresh off of a restart of the computer (an end of year 2013 iMac). Restarted Ppt several times with the same glitch happening.


#13

Thanks. Clearly part of the system thinks that window is still on the space you moved it from.

I will need to investigate why that could be. It’s very annoying that I can’t reproduce this, but I’ll try some more and I’ll have a good look at the code and see if I can find a possible resolution.


#14

Thanks so much!


#15

I hope that it’s fixed in this version:

http://downloads.binaryage.com/TotalSpaces2-2.1.8.zip

Please could you install it and verify?

Thanks!


#16

Hi Stephen,

I just downloaded and tried the new version. Sorry to say, PowerPoint is still jumping back and forth between windows.

Kevin


#17

Oh, that’s a blow.

I found I was able to reproduce the issue, and I found a way to fix it with this update. At least it’s fixed on my system. There must be a further problem of some sort.

I’d like to at least check that this install worked correctly - any chance you could Console.app - when TotalSpaces2 starts it should say something like this:

26/04/14 21:54:46,356 Dock[45615]: [TotalSpaces] FastSwitch2 © 2011-2014 Switchstep is association with BinaryAge
26/04/14 21:54:46,356 Dock[45615]: [TotalSpaces] FastSwitch2 is being initialized
26/04/14 21:54:46,357 Dock[45615]: [TotalSpaces] Mavericks detected
26/04/14 21:54:46,371 Dock[45615]: [TotalSpaces] FastSwitch2 ready v2.1.8

This would confirm that the correct version is being installed.


#18

Hi Stephen,

Yup, that’s exactly the output I get when I restart the application. Let’s also see if the update fixed Maxine’s problems.

Kevin


#19

HI Kevin,

I’m pretty much doing the exact same thing as in the videos. And my changes appear to have fixed this on my machine.

Are you using the move current window hotkeys to trigger the problem? (works ok for me, but this is using a different code path in the app).


#20

I installed the update.

When I only had one blank Ppt open, it was actually working perfectly. As soon as I opened one that had content in it, though, it started doing the same thing as before. I checked the console output, and it matches what you posted.

I also had another glitch when I updated it. This cleared up on its own, but when I first opened TotalSpaces after the install, it was glitching in how it detected my spaces. It wasn’t displaying my grid in settings or letting me add or subtract rows or columns. The menu icon also didn’t have a number in it. That random error cleared up after a couple of times restarting TotalSpaces, but I figured I’d let you know about it.