[RESOLVED] Totalfinder "open in new tab" always opens a new window

title says it all.

Very annoying.

Once the tab is open in its own window I have to drag it to the window where I started.

Seems to defeat the point.

Yes, Mavericks.

Uhm… it is working fine here. I can’t reproduce it.

open new tab opens a new window w/o tab bar for me. so i can not drag it into the tab bar.

What happens when you switch tabs? Does it fix itself?

What about restarting Finder.app via CMD+OPT+ESC and launching TotalFinder.app again, does the problem go away?

I ran into this same issue.

What happens when you switch tabs? Does it fix itself?

No, this did nothing.

What about restarting Finder.app via CMD+OPT+ESC and launching TotalFinder.app again, does the problem go away?

Yes, this fixed it for me! I just installed Yosemite this weekend and hadn’t used the computer for much of anything until today, so I will let you know if the issue recurs.

This issue showed up again partway through my workday today. I’m not sure what triggered it, though. Possibly it was double clicking a tab to open a split, and then closing one half of it, but I’ll need to test this (memory’s fuzzy about whether tabs were working at all after that, since I’ve been navigating the Finder quite a bit since then without really needing new tabs much). Hopefully I’ll have a chance to test this tomorrow.

I, too, have this problem. It only occurs if both the toolbar and the sidebar are hidden. This was ok until a few versions ago (1.5 something). Totalfinder does not like a spatial Finder anymore. :frowning:
10.9.5, TF 1.6.12

I’ve got both toolbar and sidebar shown, but this issue is still cropping up for me incredibly frequently (driving me a little nuts, actually; I’m able to work around it by right clicking an item in the sidebar and choosing “Open in tab” sometimes, but other times even that doesn’t work).

Worse, I can’t drag the windows that spawn when this bug occurs into the tab of my existing window. Anything I can do to help debug the problem and get it fixed?

I want to fix this for the next release. Any help isolating the issue is highly appreciated.

I have the same issue, but I don’t know why since it was working up until today =(
Tried isolating the issue, by restarting app, restarting computer, reinstalling TotalFinder (beta), but nothing seems to fix it. It’s just stuck that way… Very annoying =/

Please don’t give up on trying to find a solution!

Hi guys,

I have the same problem since switching to Yosemite: Every time I try to open a new tab, a new finder window opens :frowning:
Running version 1.6.16 on a MacBook Pro, so the last update did not help, unfortunately.
My workaround: I disabled tabs in Totalfinder, but this sucks, of course…

Any help is greatly appreciated, thanks!

Edit: On my iMac, I observe a “normal” system behavior when opening the tabs - this is weird

Hi Luftikus,

I temporarily switched to Path Finder but hated it… Then I uninstalled Totalfinder using AppZapper and reinstalled the latest beta. Don’t know exactly why, but now it’s working like a charm for me again. Try doing the same, maybe it’ll solve your problem too?

Good luck!

Got the answer: It’s not TotalFinder, it’s the Finder.

The first step here may not be necessary.

Get Deeper, or Onyx (http://www.titanium.free.fr), and, under the Finder settings, turn on ‘Show the interface level switching’, then, in the finder menu, make sure the Advanced setting is on. Maybe even switch to the ‘Simple Finder’, and back again.

Now, in the Finder, under the ‘View’ menu, turn on the Toolbar. For some reason the powers that be at Apple think that the Sidebar and Tab Bar should turn on, and off with the Toolbar. Doh!!

NOTE: I did have the problem of new windows instead of tabs, and this cured that as well. Go figure. Basically I was trying to reset everything.


Hi, on 02 Jul 2014 11:47:30 I sent a mail to support which included a very short screen capture that illustrates the problem. If you want I can resend this mail.

Cheers, Michael

1 Like

@finistere you nailed it. I looked up your email and it perfectly describes the problem. With your help I will be able to diagnose it and fix it. btw. I’m sorry it stayed without response for some reason (I got busy probably).

Cool. Let’s get it fixed then. :slight_smile:

Has this been fixed yet? I did a clean install of Yosemite and TotalFinder and I am having this problem. It doesn’t happen on my other Macs that were upgraded from earlier versions.

Can you guys test this new beta release? (1.6.19)

I was unable to reproduce it myself. But I did (again) pretty huge rewrite of the mechanism how new Finder windows get captured into TotalFinder’s frame. Chances are the problem could go away.


Out of the blue, I started having this problem tonight where opening a new tab opens a new window instead. I updated to the latest beta (1.6.19; I was on .17) and forced finder to restart, but I still experience the problem.

I’d be happy to assist with debugging/testing. Just let me know if I can help.

Thank you. We have to fix this annoying bug. I think I should prepare a debug version which will do some extensive logging, where I could figure out what went wrong.

Will be back.