Ruminations on Visor behavior (1.4.xx)

There’s been some healthy discussion on how the Visor should behave.

Some would rather it not be part of their regular Finder workflow, chiefly meaning it doesn’t come up as a place for new windows.

What do you think about an option for limiting the Visor activation to hotkeys only? I’m not saying this is possible nor easy, but am looking for brainstorm-level thoughts. Thanks!

I am here in response to Mike Maturo’s suggestion on, inviting those of us who would like to see changes to the current behavior in which the Visor window pops up when Finder is activated to weigh in here.

I would prefer that the Visor window only activate when the hotkey combination is triggered.

If I am in another application and use Command-Tab (for example) to go to the Finder, I expect the Finder to activate with whatever native Finder windows I may have already opened (or none, if I haven’t opened any), without the visor window obscuring part of the screen.

Thank you for asking!

1 Like

Looking at the visor code and there is some hidden tweak which might work as you requested.

Please try to execute this in and relaunch Finder+TotalFinder:

defaults write TotalFinderDontAutoSlideVisor -bool YES
1 Like

I’m confused. Was this post started in July 2013 or July 2012? I got irritated seven months ago when Visor’s behavior changed and it wouldn’t show when I switched to Finder via ⌘-Tab. Now this topic indicates there’s a hidden setting to give me back the prior behavior (using “NO” as the value), but that command does not, in fact, change Visor’s behavior.

Is there a way to get the prior behavior back?

@mrtoner I’m not aware that this behaviour changed. I went back through changelog and I can see that there were some changes related to Visor but nothing really specific to this.

By default TotalFinderDontAutoSlideVisor key should be missing, which has same effect as setting it to NO. So if you have never tweaked this key, you should have still the same “prior” behaviour.

In default behaviour Visor auto-slides when Finder gets activated by the system (for example via CMD+TAB) and Visor is the only TotalFinder window in the system. When TotalFinderDontAutoSlideVisor is set to YES, Visor never auto-slides. Note: It can be still activated by getting keyboard focus somehow.

Does it make sense?

@darwin Your reply makes sense. What doesn’t make sense, however, is that Visor doesn’t appear when I switch to Finder–and I’ve now removed that hidden preference (which was never ‘true’).

Looking back at that prior conversation, I see that Antonin never really answered my question. I just want to know why–on two separate machines running Mountain Lion–Visor **doesn’t appear when I ⌘-Tab to Finder.

And yet, on two separate machines running 10.8.4 and TotalFinder 1.4.18, Visor does not slide into view on ⌘-Tab to Finder. What setting am I missing that would enable this? On another machine running 10.6, Visor works as expected.

It seems a little spotty in this regard even on my 10.7.5 installation.

If I opened the Visor recently, then when I switch into Finder and there are no other Finder windows already open the Visor pops up.

If I opened the Visor recently, then when I switch into Finder and there are no other Finder windows already open the Visor pops up.

Right, even in Lion this feature worked. But in Mountain Lion, even if it is the only Finder window, Visor won’t slide into view when I ⌘-tab to switch to Finder.

Ah, perhaps now that @darwin is back in town I can get an answer to this question.

I just tested it with one space. One TotalFinder window which is Visor under latest Mountain Lion. It works as expected: CMD+Tab to Finder will slide Visor window up.

This will need some investigation of this behaviour on different systems. I’m not in full control of this behaviour. Visor sliding just react on focus events when Finder in Visor window gets or loses keyboard focus / main state. It is possible that some other apps or system changes between Lion and Mountain Lion interfere with this.

@mrtoner Can you please do a simple test? Create a brand new system user via Preferences -> Users and Groups. Then log in under pristine user and launch /Applications/ there. I wonder if you will experience the same misbehaviour. If not, please try to figure out which other app or system setting is causing the behaviour change. It could be your spaces setup, some window management utility, some background helper tool or simply another “non-visible” (Total)Finder window lurking somewhere.

I did manage to find the problem: Keyboard Maestro. I’m using its application switcher (with ⌘-tab) instead of the standard switcher. To combat the issue, I’ve created a new macro:

Activate TotalFinder

Triggered by any of the following:
Application ‘Finder’ activates
Will execute the following actions:
Type the ⌥` Keystroke

Thank you for your effort.

1 Like

As it turns out, there’s an additional macro that’s needed:

Intercept Visor Keystroke

Triggered by any of the following:
The Hot Key ⌥` is pressed
Will execute the following actions:
Set Variable ‘visor_keystroke’ to Text "Yes"
Activate Finder

Without this macro, using the ⌥` to activate Visor will also cause Finder to activate; at that point, the former macro will run and then hide Visor. I’ve modified the former macro to clear the variable used to flag the fact that the keystroke was used:

Activate Visor

Triggered by any of the following:
Application ‘Finder’ activates
Will execute the following actions:
If All Conditions Met
The variable ‘visor_keystroke’ contains ‘Yes’
Do nothing.
Otherwise, Execute the Following Actions:
Type the ⌥` Keystroke
Set Variable ‘visor_keystroke’ to Text

BTW, I asked KM’s developer if this behavior could be fixed, assuming it was a KM issue; his response is here: