TotalFinder 1.6.12 & Yosemite 10.10 Orphaned Window Issue

Quite often when I move the finder window, or minimize the finder, I’ll get an “orphaned” part of the finder window that doesn’t have the tabs or title nar or ability to move or close it. it is just stuck there until I close the original finder window that spawned it and then it closes itself. It is like the middle finder part glitches and becomes unattached from the group. Does that description make sense? Anyone else having this issue or know how to fix it? Thanks!

Long time TotalFinder fan,

Yes, we call them “ghost” windows and there are several other threads about them. This will be my focus after 1.6.14 release.


Okay, thanks for the update. I’ll read up on the other threads now that I know the right term.

Ghost windows, so this is a secret halloween feature! :slight_smile: haha.

1 Like

Hello. I have the ghost windows also. In TotalFinder 1.6.12 and 1.6.13 I have ghost windows, I even have TotalFinder tabs disabled in TotalFinder settings. But the ghost windows is still getting stuck on the desktop. They get there WHEN I have a normal Finder windows and I make a new tab (a Mac OS X tab) and then I drag that new tab outside the window. Then while holding the mouse button down and dragging outside the “mother-window” and out to the desktop area. The tab animates normally to a miniature thumbnail Finder windows while dragging the tab out from the mother-window. Then when I release the mouse button then this Finder windows I dragged out by dragging the tab shows up normally. BUT!.. If I close this new Finder windows, then on the desktop the ghost Finder window miniature thumbnail is still there. I can not activate it, and I can not close it. BUT… I can go in to Mission Control and I can MOVE/drag these small ghost thumbnail windows to a new desktop space. So they are not THAT MUCH a “ghost” because I can in Mission Control drag them between desktop spaces. But I can not maximize them to normal Finder windows and I cant not close them in any way. They stay on the desktop until jeg restart Mac OS X.

My system:
Mac Pro (mid2010) 2x 2,4 GHz quad) (8 core machine)
2x 4 GB Kingston RAM 1066 MHz (8 GB)
2x OCZ Vertex 2 SSD harddisks (2x 120 GB)
4x Western Digital - FireWire800 harddisks attached
NVIDIA Quadro 4000 for Mac graphics card.
Latest 3 gen. Yosemite NVIDIA GPU driver
Latest NVIDIA CUDA driver 5.6.18

Mac OS X 10.10.0 Yosemite (final app store release) (fully updated)
(upgraded over a Mavericks 10.9.5 fully updated)
I’m using english language in OS X.

I have reported this bug to NVIDIA and APPLE also.
But it could be a TotalFinder bug!

I have made a screenflow desktop video showing the bug.
Please see it at:

The video is using NVIDIA 30. oct 2014 GPU driver which is their 3rd version of Yosemite GPU drivers. I have had the two previous Yosemite drivers that had the same ghost window issue.
I have installed all Yosemite updates.
I have tried TotalFinder 1.6.12 and the video is with TotalFinder 1.6.13, the same bug is appearing on both of these versions of TotalFinder.
As you can see in the video I have disabled the TotalFinder tabs completely in TotalFinder’s preferences.

I have not have had installed any Yosemite beta versions.

Looking forward to your response.


@jespersimonsen Thanks for super-detailed report. These are not ghost windows I had in mind. Those are stuck thumbnails from dragging native Finder tabs around.

It is a bug triggered by TotalFinder. Here is a workaround for the problem:

What I meant by ghost windows is this:

The removal of file
did not work after I installed TotalFinder again my little ghosts came again.

But the Terminal script did remove my small ghosts:

osascript -e "tell application \"Finder\" to quit" && defaults write DisableAllAnimations -bool false &&  defaults write AnimateWindowZoom -bool true && defaults write TotalFinderDontFixInstallerDefaults -bool true


The windows I’m talking about are fullsized stranded windows of a tab without the chrome.
(i think they are unrelated issues.)

clicking on the tab that stranded them, makes them disappear, a trick i learned form another thread, so you can work around them until there is an official fix.

Can’t say I’ve encountered the smaller ghost (animated?) windows, but the large orphaned one is a frequent thing. Much to my annoyance, so at times I have do disable TotalFinder completely.

At least for me, I’ve found a way to get rid of them temporarily. Simply click on (usually) the left-most tab in the window and that will “reattach” the window to its tab. Note that you might have to do this each time you restore a window from its icon. But at least it gets rid of the orphan.

Note that I’m running Mountain Lion so this isn’t a Yosemite-only issue.

If you go to the apple icon top left and choose force quit finder they seem to disappear worked for me give it a try. Im Yosemite 10.10.2

easier to just force quit finder only a couple of clicks rather than going through the terminal and typing this script every time will get a bit onerous after the 10th time.

A quick fix is CMD+T followed by CMD+W.

Still or again seeing this behaviour - now in El Capitan and TotalFinder 1.7.3

I think it only occurs when opening Finder windows from other apps - like “Show in Finder” on a downloaded file in Chrome or “Reveal in Finder” in HoudahSpot

/Karl Erik Jessen