TotalFinder status under macOS 10.13 (High Sierra)


#41

You have to reinstall TotalFinder after upgrading to High Sierra.


#42

thanks Darwin! I appreciate the update! Just as an FYI - after I upgraded, TF made me go thru the CSRUTIL enable/disable process after the initial login to High Sierra, post upgrade. I thought that was interesting… but if I have to uninstall/ reinstall, I can do that too.


#43

Yes, you have to go through that again. Apple removes TotalFinder’s system component during OS upgrade. Also we had an issue with checking our code signature so you would have to do that with new TotalFinder version anyways:
https://totalfinder.binaryage.com/sip-versions#mark-v2


#44

After installing High Sierra from regular Sierra, I also got the issue of Finder freezing when trying to empty the trash.


#45

Did you test it with plain Finder.app without TotalFinder running?


#46

No, I didn’t really have the time. I just noticed it happened twice but I haven’t seen it since.

It might be hard for me to test at this time.


#47

I have encountered an issue which somewhat impairs usability (TF 1.10.2): if a file (not a folder) is selected in column view, the entire window content is shifted up about 2 lines, so the top 2 item are no longer visible (they may be pulled down, but rubber band back up out of sight when released). After this happens, the shift persists when switching to icon or list view. With a clean window, selecting a file in icon or list view doesn’t immediately create such a shift, but it will appear after switching to column view.


#48

Hallo, I installed MacOs 19.13, uninstalled TF and then reinstalled TF. I noticed that opening a folder with many folders inside, in list view, only some folders are coloured, other have only the coloured point. Someone else has the same behavior ? (See the image)


#49

I’ve just installed High Sierra and now Visor is not working. In the menu it’s greyed out and if I use the shortcut TF crashes and Finder is restarting. I followed the directions disabling and enabling SIP. I’ve read this thread but I can’t find anything that seems to solve the problem. I’ve tried to delete the plist files but it made no difference. What to do? The Visor feature is the most important of all!


#50

I wonder why TotalFinder’s crash watcher didn’t offer sending a crash report. Could you please try to find it and send it to support@binaryage.com. Thanks.

You can find it via /Applications/Utilities/Console.app -> User Reports -> Finder_something.crash


#51

I recently opened the Total Finder prefs and there was some weird coloring on all the text lines. See attachment.

After restarting the computer, Total Finder was either really slow to launch or didn’t launch and I had to manually launch it.

Too early to tell but something seems a bit weird. After the computer restart, the Prefs graphic issue was gone.


#52

I had that problem a while ago and determined for reasons unknown to me that my computer didn’t recognize the wireless keyboard in time for my Command-R to work. In other words, often the booting process had progressed past the Command-R stage before the keyboard was available. My solution was to go out and purchase a $10 wired keyboard. That worked so now whenever I need to boot with a Command-R (or any other booting key sequence), I plug in that keyboard to get started.


#53

I use a wired USB keyboard for just this reason.


#54

I can confirm that Total Finder often times does not automatically launch on a restart in High Sierra. It also doesn’t always launch when I double click the app in the Applications folder. It takes a few tries and some time.


#55

Hi Antonin,

My TotalFinder just crashed! I use MacOS 10.13

The crash report is available here:


#56

@TomHsiung, thanks for sharing the crash report. I have identified the problem and will fix it in the next release. The crash was caused by selecting “Disable Tabs Completely” in TotalFinder’s preferences. I was forcing Finder.app to quit forcibly and that is not safe in the High Sierra Finder.app.


#57

Sorry for all the messages but maybe what happened is that Total Finder was removed from the “Login Items” in OS X Prefs when I updated to High Sierra and I had to add it back.

I can’t remember if I previously had it included as an app in the Login Items before but that may have been it.


#58

Just installed the latest total finder in high Sierra. It does not launch. Activity monitor shows that it is running but it doesn’t show up in finder preferences, nor is it in the menu bar. I disabled csrutil and then reenabled it again after install and now I constantly get the message “Apple events cannot be delivered”. I performed this as listed on the forum…

“A WORKAROUND is to restart appleventsd process.
In Terminal.app execute this command (it will ask for your password, that is ok): sudo killall -KILL appleeventsd”

I have restarted and I still get the same error message and total finder is still not running, or I should say activity monitor shows it is running but I don’t see any evidence of that anywhere


#59

Everything works fine for me except tabs. If I try to open a new one it opens in the background and only appear (in a window) if I click the Terminal dock icon.


#60

@musyne Terminal dock icon? Didn’t you mean Finder dock icon? Also I don’t quite understand description of your tabs problem.