BinaryAge

TotalFinder Support In macOS 10.14 Mojave

question

#55

Yes - SIP confirmed disabled.
And turned off autoupdate; unsuccessful.

on v 1.11.1

06


#56

you were referring to accessibility, right?


#57

The link didn’t work. But thanks for making it an auto-update. I updated and it’s working as expected. Only remaining problem (from 1.11.0) is that in Dark Mode the Cut/Copy/Paste tabs after right-clicking a file are totally white. When you click on them, they’re there and everything works.


#58

I have none of those things in Security & Privacy/Accessibility. Is there a reason you might need them there?


#59

was trying to see if it made a difference


#60

Yes. Looks good.

Can you please open Terminal.app and execute this:

touch ~/.debug-totalfinder-injection

In ActivityMonitor.app please quit TotalFinder.app and force restart Finder via CMD+OPT+ESC.

Then please launch /Applications/TotalFinder.app again. You should now see ~/.debug-totalfinder-injection.log file with some logs. You can tail it:

tail -f ~/.debug-totalfinder-injection.log

Please send the content to support@binaryage.com. It could help us diagnose your issue.


TotalFinder not working on Mojave 10.4.2 after SIP-Fix
#61

In Security & Privacy/Privacy/Automation: Allow the apps below to automate other apps.
Total Finder
(x) Finder

Check to see if this is enabled. It’s enabled on my machine. See if that helps.


#62

So I looked into S&P/Privacy/Automation and did not find the option mentioned. There is only TF uninstaller present. Suggestions?


#63

Please try to remove it from Accessibility. And then kill TotalFinder.app via ActivityMonitor.app and then launch it again. macOS could ask again for automation permissions.


#64

You beat me to it. Both my iMac (27" Late 2013) and Macbook Pro have Total Finder in Automation.


#65

I can also see it under Automation and NOT under Accessibility. I wonder how @ans87ba installed the Mojave system. I can imagine a scenario when he upgraded the previous Sierra system in-place to Mojave without a clean install. This could bring over some accessibility flags set in the previous system and that in turn caused new Mojave “Privacy/Automation” subsystem to not be triggered (in theory).


#66

The is exactly what I did; upgrade not clean install - first time ever I select not to b/c didn’t have updated backup. I tried uninstalling and reinstalling after your suggestion but no success.
is there a way to reset the accessibility parameters?


#67

I was googling for some solution, but Mojave is so new that there are not many support articles on the web, I’m afraid. Please let us know if you figure out a way how to make it appear there under Privacy/Automation.


#68

Here you go: https://macosxautomation.com/mavericks/guiscripting/reset.html This script should work with Mojave as well. Incidentally, I did an upgrade, not a clean install on both the desktop and laptop and TF is in the automation section.


#69

Nice find!

I just looked inside the provided zip archive and extracted the applescript file to review it is not harmful. It looks good, it uses tccutil reset Accessibility terminal command, which might be extended under Mojave:

Will investigate it in a bit.


#70

Ok, I did a bit of digging in Mojave and all permissions are located in ~/Library/Application Support/com.apple.TCC/TCC.db which is a SQLite database. You can open it with some free tools like https://github.com/sqlitebrowser/sqlitebrowser.

From command-line in Terminal.app you can execute following commands:

sudo tccutil reset Accessibility

and

sudo tccutil reset AppleEvents

The first one will clear “Accessibility” permissions in Privacy/Accessibility of System Preferences. And the second one will clear the “Automation” permissions in Privacy/Automation.

Try to run both commands and then kill everything Finder/TotalFinder related and launch it again. This time it should ask you for permissions I believe.


#71

attempted terminal commands and restarted twice - not successful :frowning:


#72

Great news, it works now. Full OSX efficiency again.

  • Steinar

#73

congrats


#74

Just installed TotalFinder 1.11.1 and it’s working again in Mojave. Thanks !!:grinning: