TotalSpaces support on MacOS 10.14 Mojave

bug

#21

i won’t update to mojave until totalspaces is working. A mac without totalspaces is nearly unusable for me as of now :smiley:


#22

Hi Stephen, no news good/bad news ? :slight_smile: we’re now on Mojave beta 3 dev


#23

+1, would happily pay for an upgrade license for having this in Mojave. I’ve been without TS2 for several days now since upgrading, and its absence is brutal! =)


#24

Making progress. I have desktops switching on beta 1 - more work to do, and must port to the latest beta, but it’s looking more promising now. I’ll keep you posted.


#25

That’s exciting news. Thanks, stephen.


#26

awesome!


#27

Thanks Stephen! Super excited for this. =)


#28

Thx Steven for your hard work :sunglasses:


#29

Hi, you may try this version. It should work on the latest beta of Mojave.

http://downloads.binaryage.com/TotalSpaces2-2.7.0.dmg

Note:

  1. TotalSpaces2 on Mojave will not work with SIP turned on. SIP must remain off for it to work.
  2. There is a new system dialog about controlling Dock when you run TotalSpaces2. You should agree to this or TotalSpaces2 will not start correctly.

Of course there may be bugs/problems, please report them here.


#30

Hello Stephen, appreciate your efforts!

All my previous TotalSpaces settings are wiped away

I have 9 desktops but this how it looks in the app (can’t add desktops or assign any)

Thanks


#31

Looks like this has failed to establish communication with Dock. Can you send me diagnostics? See here:


#32

@Ahmed_Habashy - this exact thing happened to me when I installed the new version of TS. I quit and then re-started the application and everything was fine afterward - all my settings were restored. FYI, I’m using macOS Mojave Beta 18A336e.


#33

I just installed TotalSpaces on my Mac running Mojave Public Beta and it works! This is great. Good job, stephen. Thank you very much.


#34

Major problem here, swiping from one to the other space works but when I go to to the corner of my screen set to show all desktops and next choosing a desktop logs me off instantly, this is true for selecting any desktop.
Can’t go more into detail here since it’s bedtime for me, I will check this behaviour tomorrow on another Mac.


#35

Sorry for the late reply, it worked right after a restart.


#36

Yep, I can also confirm the same behavior noted by @justme. Clicking on a desktop in the Overview Grid results in an instant log-out. Yikes!


#37

After updating to 18A347e it is not working anymore

Whenever I slide Dock quits and app isn’t responding properly


#38

Might be that SIP is on again!?


#39

Nop, I ran
csrutil status
System Integrity Protection status: disabled.


#40

I have to second what other people said. It was working in Mojave Public Beta 3 but I just installed PB4 and it does not work any longer. The machine quits as soon as I click on one of the grids.