TotalSpaces support on MacOS 10.14 Mojave

bug

#61

on my beta9. Total spaces seems not working again


#62

Hey guys… long time TS user. Ive been following the forums. TS is still working perfectly for me after updated to the most current beta


#63

working for me on Mojave beta 10


#64

sometimes not launching properly on iMac Pro, I had to relaunch twice today when rebooting Mac; now ok once running


#65

Still working for me on Beta 10.


#66

On the latest beta (18A389) it’s working ok through our testing. I’m expecting it to continue working into GM at this point. Please let me know any issues. Thanks!

Oh, by the way, the latest version is https://downloads.binaryage.com/TotalSpaces2-2.7.3.dmg
See https://totalspaces.binaryage.com/changes-beta


#67

Merci !


#68

@Stephen: On version 18A389 of Mojave, TS 2.7.4 was working properly until I rebooted. Now it won’t start properly and I’m getting the following error message:

47%20AM

I checked under Automation and TS is allowed to control the Dock, and SIP is already disabled. This message repeats over and over until I quit TS (I guess TS keeps trying to inject itself into Dock and keeps failing).


#69

OK, figured it out: I recently disabled “Displays have separate Spaces” in Mission Control to troubleshoot an issue with PowerPoint and this appears to have caused my problem. Re-enabling the separate spaces gets TS working again.


#70

Hi, that’s good information, thank you very much - I’ll check what the problem is when that setting is off.


#71

Hi Stephen,
The name in the Application column seems to disappear? (Mojave 10.14 (18A389))
It’s been missing for quit a long time since some version from which i can’t remember.
image
image

There’s another issue on the menubar icon in Light appearance. The digit in the middle of the icon is missing.
image
But it’s okay in Dark mode.
image


#72

Yes that’s the second report of this issue in the menubar icon, but I can’t reproduce it on my machine. I’ll try to figure it out though.

Thanks for the report about the Apps tab, I’ll try to get a fix out today.


#73

Thanks.
:blush:


#74

There is a new release, 2.7.5 that addresses a couple o serious issues including the missing App names. I haven’t solved the invisible number issue though, will try to fix that asap.


#75

image
image

Now it works though the text color does not match the Dark theme.
Not a big issue, may be next big update. :sunglasses:

Thanks so much.


#76

Ah yes, thanks for pointing that out, it will be fixed next update.


#77

Hello Stephen,

I can get TotalSpaces to work when csrutil is disabled, but once I enable it I get the messaged that SIP must be disable for TotalsSpaces to work. I did follow the instruction when installing, and did a completely clean installation. Please respond if possible!


#78

I’m sorry to say that on Mojave, SIP must be disabled. See here for more information https://blog.binaryage.com/sip-and-mojave/


#79

I have installed Mojave and in System Preferences --> Security & Privacy --> Privacy --> Automation, Dock is checked.

TotalSpaces2_Dock

When I (re)boot my Mac I still get the error “TotalSpaces2 failed to start” after login.
TotalSpaces2 is working fine, but the error message after login is confusing.


#80

Hi Stephen,
I also have a error in my iMac middle 2015 with the new OS mojave.
Here I share with you my error:
23

I already installed the version 2.7.2 and looks work. Except when I try to create more than 20 screens.

I want said thanks so much for develop this software. I can live without him :slight_smile:

Thanks!