BinaryAge

TotalSpaces support on MacOS 10.15 Catalina

I just uploaded v2.8.2 https://downloads.binaryage.com/TotalSpaces2-2.8.2.dmg

This should fix the various issues and should work with catalina beta 5. Please let me know how it goes if you try it.

2 Likes

Stephen, well done! Everything works now.

You got my Upvote.
Shame though that we have to go this way to install an App.
Terminal is not really an App for most people, even though it’s actually not that hard to copy and paste a terminal command.
If it was just that, even sadder is that SIP must be off, that’s not an easy task for most people.

Pretty sure a script could run when you install an App to mount the disk as read/write, not to sure if that would be possible for turning off SIP.

On a fresh install 2.8.4 does not work. It installs fine but cannot start. The notification asks me to enable automation in security & privacy preferences but TotalSpaces2 is not listed. I am using the trial version, as I do not want to spend money until I can see it working.

Thanks for the report, it looks like there was an error in the build of this version meaning it would not install correctly if it had not previously been installed: Please try https://downloads.binaryage.com/TotalSpaces2-2.8.5.dmg

2 Likes

2.8.5 is working as expected. Seems if one had a lot of screens with alot of spaces … you had to goto MIssion Control … hold option … and delete the excess to get it below 16 … the max for Total Spaces.

Very weird. 2.8.5 working on my MacBook Pro but not my iMac as of this morning. Both using Catalina.

Emailed my console logs as well.

It’s not starting correctly, but I’m not sure why. Most obvious guess is that something went wrong with the permissions. Try this in the terminal (it will reset the “Automation” controls in your security settings, so any app that uses that will request access again).

tccutil reset AppleEvents

Then start TS2 and okay the permissions dialog.

Still doesn’t work. :frowning: