TotalSpaces2 status under OS X 10.11 (El Capitan)


#64

FYI: I didn’t turn off any security protections. My version of El Capitan no longer has that option in Recovery Mode.
My recommendation is to continue selling TotalSpaces2 from your website and forget about the Apple store.

Thanks,
Al


#65

I guess you now have to use the Terminal in Recovery mode, and use the csrutil command. But it still seems to be in flux, we’ll have to see how it turns out.



TotalFinder status under OS X 10.11 (El Capitan)
#66

I haven’t updated to Beta 8 yet… Does it break TotalSpaces? Beta 7 seems stable enough for now, so I’ll wait for some other brave soul to try it out.


#67

Beta 8 should work ok with the existing release, but I also have an improved one (fewer UI glitches) - I am continuing to test it at the moment, should be able to release it soon.


#68

I’ve installed Beta 8 and all is still working well.


#69

Installed the GM and it’s working great! Animations and swiping (using BetterTouchTool).


#70

Yes, no significant changes underneath, so grid spaces live on! I am going to build v2.3.3 tomorrow or so and upload it here, it has some improvements.

I’m also looking at if we can selectively enable TotalSpaces without having SIP completely turned off.


#71

I actually can’t seem to get the “Move current window” Hotkeys to work or move a window by dragging it and holding it on the edge of the screen. Does this seem to be working for you? Everything else seems to be working perfectly.


#72

Yes, I see that. The move window functionality is not working. I need to investigate that, thanks.


#73

where is my 2.3.3?


#74

Here:

http://downloads.binaryage.com/TotalSpaces2-2.3.3.dmg

  • More stable overview grid transitions
  • Quitting an app from fullscreen should work ok now
  • Move current window hotkeys are fixed
  • Let me know if it breaks!

#75

Hey @stephen, just tried out 2.3.3 on the GM release, I still don’t seem to have working hotkeys for moving the current window unfortunately.

I’d just like to say a massive thank you to you for your hard work in getting this working on El Capitan! This tool is probably the single most important part of my workflow.

Is there any data I can provide you with to help figure out why moving windows isn’t working?


#76

@SeerUK What kind of config do you have? Multiple monitors? Or just a single screen?
If multi monitor, do you use a single desktop across them, or the screens have separate spaces setting?


#77

Actually even though it does work on my machine, I see there are problems with the window you moved sometimes appearing on both the space it was moved from and the space it moved to at the same time. I will do some further work on this.


#78

@stephen, single screen in this case, I have 9 spaces in a 3x3 grid. If it’s any help, I’m on a mid-2014 15" base model MacBook Pro.


#79

@stephen In my case this happens every time. When moving screens between spaces the screen gets copied to each new space for each move and for every app I’ve tried. The only way to get an app back in only one space is to relaunch it. Other than that the update is a bit smoother, good work.


#80

Also sometimes when the “Zoom to overview grid animation” is set to None, it’ll just stop allowing you to get to the grid unless you go to preferences and change it. I can then change it back to None and it works fine for some reason until it’ll randomly stop again.


#81

This version should fix the move window problem:

http://downloads.binaryage.com/TotalSpaces2-2.3.4.dmg

I will investigate the problem with overview grid, thanks.


#82

@stephen, sadly I still can’t move the windows between spaces. I’ve tried it with different keyboard shortcuts, and I’ve tried closing pretty much everything I can close to try ensure it’s nothing conflicting, but alas, nothing has worked.

The thing is, it’s still moving between spaces, it just doesn’t bring windows with it. Any other information I can provide?

If I didn’t use my laptop for work I’d just do a fresh wipe and see if it made a difference. I upgraded from Yosemite 10.10.5.


#83

Thanks for the report - it’s working perfectly for me, so I’m going to try to imagine what could the problem be - obviously there is something I am relying on that isn’t true on your machine.

Possibly I’ll make a build with additional debugging output.