TotalSpaces2 status under OS X 10.11 (El Capitan)


#84

I think I’ve discovered the issue. Here is a new build:

http://downloads.binaryage.com/TotalSpaces2-2.3.5.dmg

Also this fixes the overview grid bug.


#85

Hi @stephen, I can confirm and am happy to report, this is now working perfectly for me! Thank you so much!


#86

Hi @stephen, for me as well working perfectly! Thanks very much!


#87

@stephen Have any other users reported kernel panics when using csrutil to disable System Integrity Protection? I am trying to get 2.3.5 to run and before I even install it, just trying to boot with SIP disabled is causing a kernel panic… Any ideas?


#88

Cripes, no, not heard of that. You are able to boot ok once you turn SIP back on?

Do you use

csrutil enable --without debug

or just

csrutil disable

?

It seems you aren’t the only one, see here https://www.reddit.com/r/osx/comments/3kjc9l/help_csrutil_disable_causes_kernel_panic/
but no concrete solution there unfortunately.


#89

I just used

csrutil disable

I will give the other a try.

If I enable and reboot with

csrutil enable

the machine will boot once again (though TS2 isn’t active).


#90

I just did a clean install of the released App Store version of El Cap on a MacBook air that had never had a 10.11 beta installed. Installed the TS 2.3.5 beta before the update.

After the update, I rebooted into recovery, opened terminal and used the csrutil disable command, then rebooted. TS (and Total Finder) are both working fine and no kernel panics over here (so far).

Not sure what the solution is to the kernel panics, I’m afraid, but just wanted to add another data point that I’ve gotten it working without issue.


#91

Hello!

I have purchased TotalSpaces2, and have been loving it.

I do however not want to turn of the new security thing if I don’t have to, as I don’t understand the full extent of this. I don’t want to leave my computer vulnerable, especially when I do not understand the full implications.

The only thing that I really need from TS2 at the moment, is to disable the hideous animation from OS X.

Is it possible to do this without disabling? Would it be a lot of work? I can certainly pay you to develop this extension.

Best regards,
Chris


#92

Hi Chris, there is no way I know of to remove the animations without altering the running system software, hence the need for removing the SIP “debug” restriction.

I’m really sad about this, there are many people like yourself who can’t bear the animations (or in some cases get nausea from them).

I’ll continue to think about it though, and to monitor what Apple allow in the future.


#93

I have not tried any of the totalspaces betas. I only upgraded today and found out about SIP.

I also use bartender which has offered an upgrade that enables full functionality without disabling SIP. If you do not upgrade then full functionality requires disabling SIP. I don’t know what steps the developer took but it might help…

David
http://www.macbartender.com/system-item-setup/


#94

David, it’s interesting - Bartender seems to use a Menu Extra to load code into the SystemUIServer. This achieves control of the menu items without violating the SIP rules. It’s a kind of loophole, but Apple have allowed it for now it seems.

Unfortunately, it doesn’t help much with TotalSpaces2 which needs to load code into the Dock process.


#95

Ah well worth mentioning. I won’t be using totalspaces until the SIP issue is fixed as the links you point to seem to suggest that it should not be turned off.


#96

Maybe I missed it, but does anyone running an external monitor with a MPB loose access to that monitor once you make the command line change for TS in El Cap? Once I changed back, I once again had a live screen on my external monitor. I run 3x3 on both the MBP and SyncMaster.


#97

Stephen - I took a photo (sorry - it’s a tad blurry but still readable) of the kernel panic screen in the hopes that you might derive something from it (at a minimum, perhaps enough to tell me if there is some 3rd party app or something that might be contributing here).

Let me know if this helps on the kernel panics…

Thanks,
Greg


#98

@EbE404 can you tell me how you went about doing the clean install and perhaps more important, what are all the things I will need to reinstall/redo if I do this? (clean installs under Windows are a nightmare - hoping it’s not the same "start from scratch sort of thing with reinstalling all of your apps, etc).

Thanks in advance,
Greg


#99

FIXED!!! I FIGURED IT OUT! So the Kernel Panic in my case was being caused by the NetGear Control Center app which came with my router to allow sharing of printer connected to the router via USB. Uninstalling Control Center and then rebooting allowed me to disable SIP and NOT get the panic!

I’m going to proceed with TS2 install now. I expect all will be well in my world once again.

@stephen: HUGE KUDOS on TS2 in general and your work figuring out how to get it going under El Cap. I have really liked the app but didn’t realize just HOW VALUABLE it is to me until I lost it. I have about 5 different monitor configurations I end up with between working from home, going into the office, and a couple other common destinations and not having TS2 really messed up my productivity having to reorganize my spaces and such every time I moved. I absolutely LOVE TS2…


#100

Outstanding and thanks for posting the solution!


#101

Let me start by saying just how much I love TotalSpaces - I’ve been using it for years and it’s one of my favourite OS X utilities. Kudos to all involved!

Now, on to my issue… I’ve not had any problems with TotalSpaces2 2.3.6 under El Capitan (fresh installation of 10.11 and then Migration Assistant to copy data - SIP enabled, except for debugging attachment), except for one thing - my registration data doesn’t seem to work. Every time I start TotalSpaces2, I get a message to state that the trial period has expired and that I must register. Hitting the Registration button shows my name and serial number and hitting Register seem to work, until I start the app again. Then I get the message to say the trial period has expired, etc.

Any ideas? Has anyone else seen this?

Update: I’ve just spotted this thread. Whoops! That fixes the issue.


#102

Hi, yes, there will be a new release with this fixed soon. It’s due to a dumb mistake that is sensitive to the fact that you have a space somewhere in the path to TotalSpaces2.

Here is the fixed version:

http://downloads.binaryage.com/TotalSpaces2-2.3.8.dmg

(Update: Okay, good it’s fixed with this update!)


#103

Thanks for the quick response. Indeed. I do have TotalSpace2 in a directory with a space in the name. That updated version resolves the issue :smile: