TotalSpaces2 status under OS X 10.11 (El Capitan)


#125

OK problem solved. I had to remove TS2 from my Login Items under Users & Groups in System preferences, then Trash TS2, reboot and install TS2 v2.3.9 then reestablish TS2 in Login Items. It was worth it though as everything’s working again and I can stop shouting at my MB Pro :wink:


#126

Hi, ok… I don’t know what was wrong with it, but really happy you got it working!


#127

Hi guys, I seem to run into a new problem: The SIP hack worked on my old MacBook Pro (15-inch, Late 2011), but i tried to do it a brand new system MacBook Pro (Retina, 15-inch, Mid 2015) and the csrutil commands are simply not recognized/available in the ‘Recovery mode’ terminal window.

Is csrutil something to be added to the newest EFI, or could there be another issue I’, not aware of?


#128

I’ve seen systems where the Recovery partition is not the same version of OS X as your main system. I haven’t yet figured out how to upgrade the Recovery partition, but this is a problem we need to solve.

In the past I’ve had Recovery partitions go missing, and I use this tool to create a new one:
http://musings.silvertooth.us/2014/07/recovery-partition-creator-3-8/

So in your case, you might need to delete your current Recovery partition (perhaps using diskutil via the command line), then create a new Recovery Partition with the above tool.

However, I’m not comfortable suggesting you do this, so you might contact Apple about the issue first. Unless anyone else has a suggestion?


#129

Hi Steve,

Thanks for the suggestion, I also found other sites pointing to the same problem/solution of the recovery partition. I’m going to dive into that the coming days.

Then a different question: I’m also using the program ‘Bartender’ which required sort of the same hack to get it working under 10.11, but now they have released a new version that doesn’t require this hack anymore (see https://www.macbartender.com/blog/osx-el-capitan-compatibility/). Of course the software is not the same, but does this mean that eventually Totalspaces will be able to run without the csrutil hack? Or do you think the hack will always be needed?


#130

Hi, I can answer that one: I looked at what bartender did, and it appears they use a mechanism that apple have either overlooked or deliberately made an exception for that allows them to get code into the system ui server. This mechanism only works on that process, it doesn’t help us get our code into the Dock process alas.


#131

Hello Stephen,
I was using TotalSpaces 1 and 2 for a long time up till last spring. Do you already have a lead for that Apple-security problem? Is there any change that you solve the problem?
Paul


#132

For OSX 10.11 and 10.12, modifying the SIP configuration is the only way to be able to run TotalSpaces2. The SIP system specifically targets the way TotalSpaces works, we don’t expect to be able to circumvent it.

See also http://totalspaces.binaryage.com/elcapitan-with-sip though.


#133