TotalTerminal activation not working correctly in Yosemite

I know that Yosemite is in beta right now, but it’s always good to get a head start on future issues.

With the latest install of TotalTerminal of Yosemite, activation is not working correctly. To be more specific, TotalTerminal starts correctly. However, within about thirty seconds of using other applications, using the keyboard shortcut that usually activates TT results in nothing happening. In fact, the terminal application seems inaccessible and frozen until starting Mission Control, at which point TT shows up suddenly as if it was hidden before. This bug is peculiar, because as I mentioned the failure to activate TotalTerminal only occurs after about 30 seconds after being in other applications.

Let me know if I can do anything to test or debug this on my machine.

Thanks for reporting. Much appreciated.

Right now, TotalFinder has higher priority for me. When I get first Yosemite-compatible beta out, I will look into TotalTerminal.

btw. I have been using TotalTerminal under Yosemite for several days and I didn’t notice it, but I wasn’t using terminal intensively…

I’m having the same problem on Yosemite. It seems like if I don’t use TotalTerminal for about 30 seconds (like the OP was saying), pressing the hotkey to open it does nothing for up to one minute, and then TotalTerminal just appears with no animation.

So I’ve been scanning Console for error messages from TotalTerminal, with no results.

However, when I checked the option to run TotalTerminal as a process in the preferences menu, I found that it worked normally without the problem we’re experiencing (although running as a process and not alt-tabbable).

Obviously this isn’t a fix for the issue but a good reference point.

1 Like

Encountering this as well. It’s really frustrating. Used to work with the beta-1.

@darwin The problem is inconsistent. Specifically when you hit cmd-cmd (or your activation sequence) it intermittently won’t work. If you try to click the menulet at this time, it’s locked up, but eventually snaps out of it.

Also, and this might seem weird. When this happens, I can click on the Desktop and suddenly the activator works. Of course it could be a coincidence, as eventually the freeze times out and the activator works on it’s own.

Best of luck with Yosemite updates for TotalFinder.

It used to work fine for me when running Total Terminal as a background process. But now with DP4 it doesn’t seem to work at all anymore… Anybody else having the same problem? I tried reinstalling twice but Totalterminal doesn’t even show up in the Terminal Settings anymore.

I love this app, hope it works again soon. :slight_smile:


Yes, TotalTerminal-1.4.11 is broken on Yosemite Beta 4. It worked until Beta 3 for me.
Konsole says:

22/07/2014 11:29:52.645 TotalTerminal[1079]: requesting injection into[1328]
22/07/2014 11:29:52.723 TotalTerminal[1079]: shell is corrupted

1 Like

Same here. Worked pretty good on Yosemite b3, but it’s broken in b4.
Willing to donate money so this is fixed quickly.

Yes, I can confirm that TotalTerminal is also not working at all in DP4, even in “run as process” mode. Does anybody have a DP3-DP4 changelog so we can figure out what changed in the Terminal app to make this happen?

I will look into that today. Unfortunately my thunderbolt adapter broke and all my external disks with Yosemite installations are inaccessible. Installing Yosemite on my primary disk, but it will take some time… with all updates.

For some reason code-checking call fails for TotalTerminal.osax bundle.

A workaround is to inject TotalTerminal from manually:

osascript -e "tell application \"Terminal\" to «event BATTinit»"
1 Like

thx :smiley: works as temporary solution

pleeeeeez fix soon

Thanks a lot darwin, that works for now :slight_smile:

Thaaaaaaaaaaaaaanks a lot, dude!! =D

I found the problem. Embedded Sparkle framework has copied binaries instead of symlinks. Yosemite is more strict about bundle structure and fails code-sign checks when framework structure is malformed.

It will be fixed in a new release in a few days. I will also review keyboard shortcuts-related code.

THANK YOU for the quick response and work-around.

I have just released TotalTerminal 1.5 on pre-release channel:

This fixes Yosemite “shell corrupted” issue during launch. I did lot of refactoring and code cleanups. I don’t think I have fixed the keyboard shortcut problems. I was unable to reproduce it on my Yosemite DP4 systems. At least I have reimplemented double-tap code, which could help.

Please report back while I have it my head. I will try to improve 1.5 with additional several releases over next few weeks.

1 Like