[Update Discussion] TotalFinder 1.15.1 for Apple Silicon and Intel — macOS 13, 12, 11, and 10.15

@eBara Thank you for the very helpful information!

I guess this stupid Apple bug is worse than I thought, lol — I wasn’t aware it was possible to end up with a file/folder that is broken in the way that yours is.

(※ The broken files/folders I was able to produce during development had the correct value stored in com.apple.metadata:_kMDItemUserTags, but com.apple.FinderInfo was either missing entirely, or had no tag/label colour information. I guess the opposite can happen too, huh.)

I have already fixed this locally in my development build, and the fix will be pushed alongside the upcoming TotalFinder 1.15.1.


@akemin_dayo I just wanted to let you know that I updated to latest TF yesterday (it actually prompted me before I got a chance to go from 12.6 to 13.1, so I updated and then just now I updated to 13.1 on my silicon laptop and all went super smoothly. Once I was on 13.1 it just needed to enable for arm64e ABI support and I clicked to do that automatically and once I restarted everything was perfect.
All I can say is :heart: :heart: :heart:! You’ve really made my day.


thanks for your work @akemin_dayo, i can’t use macOS without totalfinder

1 Like

The latest version adds improved support for IconChamp but does IconChamp actually work? I’ve tried changing my home folder icon and IconChamp is unable to change it, even though it claims it can.

Is there something about Monterey or possibly TotalFinder that is preventing the custom home folder icon from being applied and displaying?

@strafer IconChamp works on macOS 12, but is currently broken on macOS 13.

That being said, TotalFinder implements IconChamp support in such a way that it will be able to apply the Finder icon from IconChamp regardless of whether or not IconChamp’s hooks are working or not.

(Also, you can change your home folder icon by simply using Get Info on it!)

(Also, you can change your home folder icon by simply using Get Info on it!)

Never thought to try that. I thought the home folder required an app to change the icon. But weirdly, both IconChamp and CandyBar were unable to do it, but simply pasting it in the Get Info window worked. Thanks.

If only there was a way to change the icons in the Finder toolbar. I despise the glyphs that Apple uses now in Monterey. I miss having colourful icons for Applications, home, etc in the Finder toolbar.

1 Like

Well that’s what TotalFinder is for…

Total Finder can change the icons in the Finder sidebar. I’m talking about the Finder toolbar.

1 Like

Oh ok I see, Yes I misunderstood you.

Just a quick update. OCLP (v0.6.0) released Ventura compatibility for my machine (MBP6,2).

Unfortunately, the injection issue found previously in Monterey with OCLP still persists. I was so hoping it would’ve been built different. I have both installed for troubleshooting purposes.

1 Like

@ChrisOSX Ah, yeah I heard about OCLP 0.6.0 and 0.6.1 (which actually have regressions regarding building kernelcaches for the root patches used on macOS 12 Monterey…)

I haven’t yet tested to see if 1.15.1 works with a Moraea’d 13.2 on my test MBP5,1 yet, but it… hopefully should.

If all goes well, I will push TotalFinder 1.15.1 soon.


I just downloaded OS13.2.1 and that seems to have broken TotalFinder again. :frowning:

Works fine for me!
Haven’t noticed anything since the update yesterday, even after reboot.


1 Like

I rebooted and now it works!


Compatibility report: TotalFinder 1.15.0 works with macOS 13.2.1 22D68 Ventura (※ released 2023/02/13)!

Apple recently released a new security update, macOS 13.2.1 22D68 Ventura on 2023/02/13.

I can confirm that TotalFinder 1.15.0 works fine with it, with no regressions in functionality.

Apple’s security patch notes are linked below for your reference.

As always, thank you for using TotalFinder.


Hi, installed it on my MacBook Pro M2 fresh install with latest Ventura and doing all the steps in the tutorial ( only disabling SIP partial )
and I noticed my GPU Memory usage suddenly is insanely high - start with 90 % instead off the 11% I had before and then goes down to around 50-60% but still 6 times as much as before. see my screenshot. activated is:
keep dock icon
show progress bar

  • hide icon in menu bar
    colored labels on
    use finder icon rendering
    tabs disabled completley

I just uninstalled total finder and reset all SIP etc settings according to tutorial - I now still have a full memory usage and so my macOS is now totally broken I suppose and I habe to do a clean install again… I was sooo hoping to use total finder again and appreciate all the work put in… but of course this is a dealbreaker for me I need that memory for video editing in resolve etc

one thing to consider because I only now saw it, because I didn’t have the app yet to check for it.
If you use the app iStatistica Pro, then you see how much memory of the shared memory is assigned to the GPU.

This shared memory always varies all over time, and it greatly varies if you open big apps.
You also constantly see the free memory.
Out of these two, the percentage is calculated, and that is persistent with istats pro, or Istatistica pro.
So the pure percentage can be misleading, still, I win now from a 10% to at least 25% over sometime in mostly 50 to 60%, so something really must be wrong, maybe a memory leak, or it has something to do with SIP or security level or similar.


found a funny behaviour. So for the reason you use Timemachine from MacOS, then go into it and restore any file you want. After this Timemachine action, TF windows can be taken apart with the mouse and it’s not so resposive anymore.

When restarting TF it’s fine again!
Just to let you know for the next update.

thanks for keeping this great helper alive.
With Ventura on Intel, colored labels are working backwards. This means, when there are several tags the oldest one determins the colour. Would be great to change this to the newest tag determins the label color - as it was before. or is there a way to change this? In the moment you need first to remove all tags to change the color of the label.
Thanks anyway.