[Update Discussion] TotalFinder 1.15.1 for Apple Silicon and Intel — macOS 13, 12, 11, and 10.15

I rarely use multiple tags, but I tested this and can confirm I’m seeing the same thing. TF 1.15.0, macOS 13.1.


I am unfortunately completely unable to reproduce any of the symptoms you are describing here.

The fact that the effects persisted even with a stock Finder (and/or with TotalFinder completely removed) is even stranger to me.

That being said, there is one difference in our testing environments — I do not own an M2 machine.

It is entirely possible that this may be some kind of bizarre issue that only occurs on M2 machines. (※ However, I have received no other such reports from other M2 users…)

This is a bit of a large ask of you (and it’s totally fine if you are unwilling to do so), but would it be possible for you to install a second copy of macOS to a new APFS volume (here’s Apple’s instructions on how to do so), install TotalFinder on it, and see if it still reproduces for you with this clean state?

This way, it should not affect your current main macOS install that you are currently using.

Again, it is totally fine if you do not want to do this.


Huh. That’s… odd. I can’t quite reproduce this one. What version of macOS is this occurring under? Are you starting Time Machine with no Finder windows/tabs open at all?

The most helpful way to demonstrate this bug would be via a video, but I understand if you are unwilling to do so.

(※ To help preserve your privacy, you can perhaps attempt to recreate the environment by making a new folder and creating a file inside of it, triggering a Time Machine backup, deleting the file, then trying to restore said file.)

@Smallersen @RickO

Ah… I see what happened here.

So TotalFinder actually does handle multiple labels on a single item, as that case is included as part of my standard test suite for my rewritten Coloured Labels code used on macOS 13.

It’s… just that I thought using the oldest label colour would be the “correct” implementation. I’m seeing now that I was very mistaken.

Upon further inspection, it seems that Apple themselves actually use the “apply the most recent label colour” behaviour in Finder too, particularly for compatibility with older macOS / OS X versions that did not support multiple labels.

Additionally, even from a UI design perspective, the most recent label colour is indeed drawn at the top of the stack.

I will correct this behaviour in TotalFinder 1.15.1.

Thank you for reporting!

Regarding TotalFinder 1.15.1

Apologies for the long period of waiting, and thank you all for remaining patient.

TotalFinder 1.15.1 will be released at the very latest by April 9th.

(※ As always, please understand that there may be a short delay even after the above date depending on Antonin’s personal availability, since all releases are still compiled/built, signed, notarised, and uploaded entirely on his side, and he is quite busy these days with other commitments.)


Compatibility report: TotalFinder 1.15.0 works with macOS 13.4b1 22F5027f Ventura, macOS 13.3 22E252 Ventura, macOS 12.6.4 21G526 Monterey, and macOS 11.7.5 20G1225 Big Sur!

Apple recently released… uh, a lot of updates:

  • macOS 13.4b1 22F5027f Ventura DeveloperSeed (2023/03/29)
  • macOS 13.3 22E252 Ventura (2023/03/28, 2023/03/22)
  • macOS 12.6.4 21G526 Monterey (2023/03/28, 2023/03/22)
  • macOS 11.7.5 20G1225 Big Sur (2023/03/28, 2023/03/22)

I can confirm that TotalFinder 1.15.0 works fine with all of them, with no noticeable regressions in functionality.

Apple’s security patch notes are linked below for your reference.

As always, thank you for using TotalFinder.

※ No security patch notes are available for 13.4b1 22F5027f DeveloperSeed, as it is prerelease software intended for developers to validate functionality of their software (such as TotalFinder! ;P) with upcoming OS releases.


Status update: TotalFinder 1.15.1

The final code is done and has been submitted to Antonin for compilation, packaging, codesigning, and notarisation.

It will be available on the beta / pre-release channel whenever he has time to do so.

Apologies for the wait — things have been unexpectedly busy for me recently.


This isn’t actually related to TotalFinder at all, but rather your previous enquiries regarding IconChamp.

It appears that some beta versions have been released which — according to this GitHub commentmay resolve compatibility issues with macOS 13 Ventura.

The latest version as of this writing in the IconChamp beta appcast appears to be 1.2.1 which is quite a bit newer than the current stable 1.0.1, so perhaps try giving that a go.

(※ I haven’t personally tested this yet, so I can’t really tell you if it works or not. I will update this post sometime later when I get around to testing it on macOS 13.)

It seems that these beta builds are posted and discussed in the MacEnhance Discord server (which I only just now figured out how to even get into, since the Discord URL on their official website does not actually lead to a valid invite ID…) — if you are interested and have a Discord account, the invite ID is zjCHuew, which can be found in the MacForge README. You will probably have an easier time keeping up to date with updates to IconChamp (and associated projects) there.


TotalFinder 1.15.1 has been released for macOS 13, 12, 11, and 10.15! (changelog)

Download TotalFinder 1.15.1 here: https://downloads.binaryage.com/TotalFinder-1.15.1.dmg

The first post in this thread has also been updated accordingly.

As always, thank you all for remaining patient, and for your continued interest in TotalFinder.


Thank you very much! :slightly_smiling_face: :upside_down_face:
Please thank Antonin also from me!

King regards


@akemin_dayo: I use IconChamp 1.01 in Ventura (just change of all generic folder icons) without further issues.
It stopped working after the update to Ventura. I removed every file with Iconchamp in the name (manual deinstallation) and installed Iconchamp new - It worked again.
SIP completely disabled.

First let me start off by saying Thank You for your continued effort to maintain this project. I imagine it’s not easy, esp with so many different variables involved (OCLP, Hackintosh etc etc).

Unfortunately, it appears I’m doomed to not having this running. I’m on a fresh install of 13.3.1 from 13.4b (issues).

In the screenshot, on first install I get the Disable Library Validation prompt. I click Disable, then it reboots Finder and shoots the Apple Events cannot be delivered error. Even after a reboot. I did look through the diagnostics log in console. It appears it’s not recognizing I’m clicking “Allow” when it prompts in the Notification Center.

04/18 06:42:45 dbg | reading internal preference TraceLogLimit => '4000'
04/18 06:42:45 dbg | reading internal preference TraceLogPath => '~/Library/Logs/totalfinder-agent-trace.log'
04/18 06:42:45 dbg | Main: arc=2
04/18 06:42:45 dbg |   argv[0]=/Applications/TotalFinder.app/Contents/MacOS/TotalFinder
04/18 06:42:45 dbg |   argv[1]=--post-install
04/18 06:42:45 dbg | gRunningPostInstall=1
04/18 06:42:45 dbg | AgentAppDelegate init
04/18 06:42:45 dbg | AgentAppDelegate applicationWillFinishLaunching notification NSConcreteNotification 0x600002f91a00 {name = NSApplicationWillFinishLaunchingNotification; object = <NSApplication: 0x7fe8051065c0>}
04/18 06:42:45 dbg | Call registerUserNotificationCategories
04/18 06:42:45 dbg | Call setupUserNotificationCenterDelegate
04/18 06:42:45 dbg | AgentAppDelegate applicationDidFinishLaunching notification NSConcreteNotification 0x600002f87c60 {name = NSApplicationDidFinishLaunchingNotification; object = <NSApplication: 0x7fe8051065c0>; userInfo = {
                   |     NSApplicationLaunchIsDefaultLaunchKey = 1;
                   | }}
04/18 06:42:45 dbg | reading internal preference CFBundleVersion => '1.15.1'
04/18 06:42:45 inf | TotalFinder.app (Agent) v1.15.1 started
04/18 06:42:45 dbg | Called installLoginItemIfNeeded
04/18 06:42:45 dbg | Call isLoginItemInstalled
04/18 06:42:45 dbg | Call installLoginItem path=/Applications/TotalFinder.app
04/18 06:42:45 dbg | Launching script: tell application "System Events"
                   |   if login item "TotalFinder" exists then delete login item "TotalFinder"
                   |   make login item at end with properties { name:"TotalFinder", path:"/Applications/TotalFinder.app", kind:"application", hidden:false }
                   | end tell
04/18 06:42:46 !!! | Unable to install TotalFinder login item: {
                   |     NSAppleScriptErrorAppName = "System Events";
                   |     NSAppleScriptErrorBriefMessage = "Not authorized to send Apple events to System Events.";
                   |     NSAppleScriptErrorMessage = "Not authorized to send Apple events to System Events.";
                   |     NSAppleScriptErrorNumber = "-1743";
                   |     NSAppleScriptErrorRange = "NSRange: {109, 133}";
                   | }
04/18 06:42:46 dbg | requesting authorization for user notifications
04/18 06:42:46 dbg | got response for [UNUserNotificationCenter requestAuthorizationWithOptions] granted=1 error=(null)
04/18 06:42:46 dbg | Call checkInstallation
04/18 06:42:46 dbg | Call checkArchitecture
04/18 06:42:46 dbg | Checking current architecture…
04/18 06:42:46 dbg | Call runningOnArm => 0
04/18 06:42:46 dbg | Current architecture is x86_64.
04/18 06:42:46 dbg | Call showNVRAMRelatedAlertsIfNecessary
04/18 06:42:46 dbg | Call runningOnArm => 0
04/18 06:42:46 dbg | [AkemiTotalFinder] [NVRAMWorkflow] Detected x86_64 architecture!
04/18 06:42:46 dbg | Call runningCatalinaOrLater => 1
04/18 06:42:46 dbg | Detected Catalina or later
04/18 06:42:46 dbg | Call checkSIP
04/18 06:42:46 dbg | Checking SIP status…
04/18 06:42:46 dbg | SIP is disabled.
04/18 06:42:46 dbg | Call checkLibraryValidation
04/18 06:42:46 dbg | Call runningBigSurOrLater => 1
04/18 06:42:46 dbg | Checking Library Validation status…
04/18 06:42:46 dbg | Call checkAutomationPermissions
04/18 06:42:46 dbg | Checking Automation Permissions status…
04/18 06:42:46 dbg | determineInjectionMethod returns kInjectWithAppleScript
04/18 06:42:46 dbg | Call ensureFinderIsRunning
04/18 06:42:46 dbg | reading internal preference TargetBundleIdentifier => 'com.apple.finder'
04/18 06:42:46 dbg | Finder is not running => launching it
04/18 06:42:46 dbg | reading internal preference TargetPath => '/System/Library/CoreServices/Finder.app'
04/18 06:42:46 dbg | Call launchTargetAppAndWaitForCompletion '/System/Library/CoreServices/Finder.app'
04/18 06:42:46 dbg | Call openApplicationAndWaitForCompletion 'file:///System/Library/CoreServices/Finder.app/'
04/18 06:42:46 dbg | reading internal preference OpenAppTimeout => '5'
04/18 06:42:46 dbg | Waiting for opening app 'file:///System/Library/CoreServices/Finder.app/': timeout=5.000000s
04/18 06:42:46 dbg | Launched 'file:///System/Library/CoreServices/Finder.app/': <NSRunningApplication: 0x60000011cc00 (com.apple.finder - 2731) LSASN:{hi=0x0;lo=0x9f09f}>
04/18 06:42:46 dbg | The app with pid=2731 is still not finished launching => give it some more time: <NSRunningApplication: 0x60000011cb80 (com.apple.finder - 2731) LSASN:{hi=0x0;lo=0x9f09f}>
04/18 06:42:47 dbg | The observed app with pid=2731 finished launching: <NSRunningApplication: 0x60000011df80 (com.apple.finder - 2731) LSASN:{hi=0x0;lo=0x9f09f}>
04/18 06:42:47 dbg | Finished waiting for opening app 'file:///System/Library/CoreServices/Finder.app/'
04/18 06:42:47 dbg | The permission to send apple events from TotalFinder to Finder is not granted (errAEEventWouldRequireUserConsent).
04/18 06:42:47 dbg | Call injectIntoRunningTarget
04/18 06:42:47 dbg | reading internal preference HardInjectionDelay => '0'
04/18 06:42:47 dbg | reading internal preference SoftInjectionDelay => '2'
04/18 06:42:47 dbg | <NSRunningApplication: 0x60000011fa80 (com.apple.finder - 2731) LSASN:{hi=0x0;lo=0x9f09f}>(terminated=0) is not old enough => postpone injection by 0.841073sec (since app launch=1.158927sec, getHardInjectionDelay=0.000000sec, getSoftInjectionDelay=2.000000sec)
04/18 06:42:48 dbg | injection delay timeout fired for <NSRunningApplication: 0x60000011fa00 (com.apple.finder - 2731) LSASN:{hi=0x0;lo=0x9f09f}>(terminated=0) => inject
04/18 06:42:48 inf | requesting injection into com.apple.finder[2731]
04/18 06:42:48 dbg | prevent injection into future launched instances
04/18 06:42:48 dbg | trying to acquire TotalFinder shell lock
04/18 06:42:48 dbg | reading internal preference TargetName => 'Finder'
04/18 06:42:48 dbg | reading internal preference InitEventClass => 'BATF'
04/18 06:42:48 dbg | reading internal preference InitEventID => 'init'
04/18 06:42:48 dbg | determineInjectionMethod returns kInjectWithAppleScript
04/18 06:42:48 dbg | Call injectWithAppleScript targetName=Finder initEvent=BATFinit
04/18 06:42:48 !!! | The permission to send apple events from TotalFinder.app to Finder.app is not granted.
04/18 06:42:48 dbg | launching apple script: tell application "Finder" to «event BATFinit»
04/18 06:42:48 !!! | Failed to execute injection apple script: {
                   |     NSAppleScriptErrorAppName = Finder;
                   |     NSAppleScriptErrorBriefMessage = "Not authorized to send Apple events to Finder.";
                   |     NSAppleScriptErrorMessage = "Not authorized to send Apple events to Finder.";
                   |     NSAppleScriptErrorNumber = "-1743";
                   |     NSAppleScriptErrorRange = "NSRange: {29, 16}";
                   | }
04/18 06:42:49 dbg | shell lock does not exist, injection wasn't successful
04/18 06:42:49 dbg | reading internal preference InjectionTroublesInfoURL => 'https://totalfinder.binaryage.com/injection-troubles'
04/18 06:42:49 !!! | Troubles launching TotalFinder - Apple Events cannot be delivered.

*Sorry about the long trace log, there’s no way to add a spoiler?

Also in the screenshot, you can see that Library Validation is in fact disabled. My SIP is correct according to your previous comment for OCLP. It’s currently configured and booted as 0x807 (Untrusted_Kexts, Unrestricted_FS, Task_for_PID and Unauthenticated_Root) PID was the only value I had to add. OCLP requires the rest by default for my machine.

I tried everything again in the Trouble Lunching TotalFinder page to no avail.

Again, Thank You for your continued support and let me know if you need any additional info.

1 Like


I will install macOS 13.3.1 on my MacBookPro5,1 test machine and get back to you.

Funnily enough, Hackintoshes generally have no issues — it’s something weird going on with the OCLP patches… o)-<

Can you run the new diagnostics script at /Applications/TotalFinder.app/Contents/Resources/diagnose-totalfinder.sh in a Terminal session and send me the resulting file?

(The new diagnostics script works quite a bit differently from previous versions and collects some more useful details from a macOS install, hence why I’m asking.)

1 Like

Gathered and sent via email.

Thanks again!

1 Like

after reboot and ok to enable it works now on M! Ventura.

1 Like

Compatibility report: TotalFinder 1.15.1 works with all of the newly-released macOS versions as of 2023/04/27!

This compatibility report corresponds to the following macOS versions:

  • macOS 13.4b3 22F5049e Ventura DeveloperSeed (2023/04/26)
  • macOS 13.4b2 22F5037d Ventura DeveloperSeed (2023/04/12)
  • macOS 13.3.1 22E261 Ventura (2023/04/08)
  • macOS 12.6.6rc3 21G639 Monterey (2023/04/26)
  • macOS 12.6.6rc2 21G633 Monterey (2023/04/12)
  • macOS 12.6.5 21G531 Monterey (2023/04/11)
  • macOS 11.7.7rc3 20G1338 Big Sur (2023/04/26)
  • macOS 11.7.7rc2 20G1332 Big Sur (2023/04/12)
  • macOS 11.7.6 20G1231 Big Sur (2023/04/11)

I can confirm that TotalFinder 1.15.1 works fine with all of them, with no noticeable regressions in functionality.

As always, thank you for using TotalFinder.

Here are Apple’s security patch notes for your reference.

macOS 13.3.1 22E261 Ventura (2023/04/08): https://support.apple.com/HT213721

macOS 12.6.5 21G531 Monterey (2023/04/11): https://support.apple.com/HT213724

macOS 11.7.6 20G1231 Big Sur (2023/04/11): https://support.apple.com/HT213725

※ No security patch notes are available for the developer seed and release candidate builds, as they are prerelease software intended for developers to validate functionality of their software (such as TotalFinder! ;P) with upcoming OS releases.

List of InstallAssistant.pkg URLs, for both Intel/AMD and Apple Silicon (※ Click on “View more”): https://appledb.dev/firmwares.html?filter=Mac

List of IPSW URLs, for Apple Silicon only: https://ipsw.me/product/Mac

※ If you’re looking for the Install macOS ${VERSION}.app that the Mac App Store (or gibMacOS) downloads, simply open InstallAssistant.pkg and “install” it — this will place the standard macOS installer app in your /Applications/ folder. (Don’t worry, this won’t install the downloaded copy of macOS!)


So in a backwards way, I managed to get it working. Mostly.

Before installation, I went through and removed all traces of TotalFinder, more specifically the .lock files found in /Users/home/Library/Application Support. I deleted all three

  1. .TotalFinder.lock
  2. .TotalFinderAgent.lock
  3. .TotalFinderCrashWatcher.lock

Steps Taken:

  1. Installing like normal, while seems like it installs fine, I always get the (AppleEvents injection error).
  2. I go back through and delete those .Lock files again.
  3. Navigate to Applications, right click TotalFinder and Show Package Contents.
  4. Navigate to MacOS folder and right click open.

It opens in terminal, and that’s when I get the popup to allow control. Clicking ok adds Terminal - Finder to Automation.

Icon changes, I get menu bar icon etc etc. The only thing appearing to be missing is the “Allow in the Background”. It shows up on initial install, but opening finder after post install causes it to vanish.

When quitting Finder and TotalFinder, I have to do all of the again. If I follow those steps, but instead of clicking the executable, I try to open TotalFinder through the normal Applications menu, I get the AppleEvents injection error.

Don’t know what if any of this will help, but it’s semi working.

After a restart of macOS 13.2.1, TF 1.15.1 just stopped working for me: I just couldn’t launch it (nothing happened on double-click). I re-installed 1.15.0 - all is working again.

So an update to my previous post. TotalFinder finally (fully?) works for me now. I don’t use all the
features, so I can only report on what I know.

OpenCore Legacy Patcher has a AMFIPass Public Beta Test. Which enables AMFI and Library Validation. Weird though, I didn’t get the library validation prompt from TF, but it’s all working. That is in beta, but it’s a very good sign for those who are still having issues.

If you need anything specific from me, let me know.