TotalFinder hangs (or crashes) Finder at startup

This started yesterday, when starting up my MacBook Pro, TotalFinder loads but I get the “Application not Responding” pinwheel. I can force it to quit and the native finder works just fine. When I reopen TotalFinder, the same repeats.

Has anyone seen this issue? I find it hard to live without TotalFinder after using it for so long!

1 Like

I am experiencing similar behavior with Finder crashing when TotalFinder starts.

I have the same issue

macbookpro early 2013 os10.9.3

Yes, some people have been reporting these issues over last few days. I don’t know if it is related to 10.9.3 update or new 1.6 release. It is caused by high CPU load.

Please go to Activity and sort processes by CPU load, tell me what process is eating the CPUs. Someone reported it was iconservices agent or something similar. Cannot find his emails now.

We have to resolve it ASAP, thanks for your help.

No, it’s the Finder process (in my case).

As mentioned earlier it doesn’t exactly crash. CPU load is very high and Finder unresponsive, but after a while it finally opens. Still with almost 100% CPU load though.
Closing Finder brings down the load, opening brings it up again.

I have had to uninstall it, it makes my Mac unusable. I hope this gets fixed fast. I miss TotalFinder.

I have the same problem with my Mac Pro!

I have just installed a complete clean install of Mavericks 10.9.3.
Formated the SSD hard drive and booted from a USB key drive with OS x 10.9.3 on it.
And when I install the TotalFinder 1.6 then at startup Finder hangs (not responding) That goes on for about 15 seconds. Then after that Finder is normal and then the Dock responds normal. But the first 15 seconds after login Finder and the Dock hangs. (not responding).
Im on a Mac Pro Dual-CPU 2,4 Ghz Westmere Mid2010 (the last cheese scraper model) and it has 8 GB Kingston RAM and
NVIDIA Quadro 4000 for Mac graphics card.
With the latest NVIDIA graphics driver and NVIDIA CUDA driver installed.
And all Apple software updates installed. And my machine uses two OCZ Vertex II SSD hard disks.
I have four Firewire 800 Western Digital hard disks attached in two daisy chains. And a APC Back-UPS Pro 1500 attached with USB. the computer is running both LAN1 and WIFI internet connections.

I have installed software:

  • Intego VirusBarrier X6 v.10.6.21
  • MacScan v.2.9.4
  • CleanMyMac v.2.2.4
  • Mavericks Cache Cleaner v.8.0.6
    …and I have tried to see if there was anything wrong.
    No rootkits found or anything else found.
    Activity Monitor shows Finder hanging the first 15 seconds after login.
    (not responding)

The problem with Finder hangs in startup came when I installed TotalFinder 1.6
Looking forward to an update/fix very very soon!
Thank you developer.

I am still waiting for a update/fix for this bug in TotalFinder.

I will work on it this week. But still I haven’t been able to reproduce or identify the issue.

Good thank you developer. I saw today in Activity Monitor that Finder uses 117% CPU usage when it was hanging. Then after the 15-20 seconds it came to rest at 0,1% CPU usage as normal. I have Login Items: TotalFinder and EyeTV helper. And in System Preferences I have: Paragon NTFS for Mac 11.2.443, AirDisplay 1,7 (turned Off), NVIDIA CUDA driver 6.0.46, Adobe Flash Player, NVIDIA Graphics driver 334.01.01f01, JAVA 7 Update 55, Intego NetUpdate 10.5.14. All is the latest versions. All these was installed before TotalFinder and that did not produce the hanging at startup.

Just a quick question. Do you open TotalFinder with “All my files” in some windows? This could be the problem. I’m trying to isolate it to a reproducible case.

No, not in my case. It doesn’t make a difference which or how many windows/tabs I have opened. I’m using Finder exclusively with Visor. Turning it off also makes no difference.


Hello again TotalFinder Developer.
I have by chance I guess, solved the problem on my Mac Pro computer now.

As I stated in earlier text. I did a clean install of Mavericks 10.9.3 from a 8 GB USB Flash drive I made my self from the original Mavericks 10.9.3 installer. When installing a clean install in that way. The installer will NOT make an partition on the OSX harddrive for the “Recovery HD” it will only make a partition for the main Mac OS X system.

And the feature in iCloud in OS X called “Find my Mac” is depended on having that Recovery HD partition on the harddrive.
So I was looking on the web if anybody had got it back.
I stepped over this youtube video here:

Youtube Link

And I did what is told in the video.
I started the downloaded Mac OS X Mavericks 10.9.3 installer from “within” Mavericks 10.9.3 operating system. And allowed the installer to install the OS on top of it self so to speak!

After it was finished after approx. 20. minutes. It restarted and I logged on and everything was back to normal. Including the TotalFinder and the system did NOT hang as before.

I started the OS X Software update and the Safari, iBooks and iTunes updates had to be installed again. That was all.

My NVIDIA Graphics Driver was disabled showing me that the graphics driver from the Mavericks installer was in use now.
So I went to and downloaded the latest graphics driver for the
Quadro 4000 for Mac graphics card. The NVIDIA CUDU driver was still working so I did not have to install that again.

And then after installation of the NVIDIA graphics driver I restarted Mavericks.
And I have now tried to restart manually.
And the thing/bug about TotalFinder hangs the Finder and Dock is NO MORE!

Everything in the system and my documents, mail, bookmarks etc was still in tact on the system. Only the NVIDIA graphics driver was altered.

In the iCloud setting I now have my “Find my Mac” turned on.
So that worked also for the better. That means my Recovery HD partition is back onboard the main harddrive.

In Activity Monitor app there is not any hanging anymore when login in the system. So I guess I was somehow lucky. Two problems solved.

So it might be worth to try to do what I just did.
Remember to have a backup before trying.

Jesper Simonsen

1 Like

Hi for me it was solved by fsck repair of the drive. Apparently there were some problems which repaired nicely. Then I reinstalled total finder
ALL good!

1 Like

Interesting. I’m glad you have resolved it.

Hope this won’t affect more people.

I just reinstalled TotalFInder…it crashed my Finder again, so I have uninstalled it again. I really miss using your app, but I just can’t. I have reinstalled my OS, it didn’t help.

Could you find and send me your latest Finder crash report to ?

It is in -> User Diagnostics Reports -> Finder_something

fsck did nothing for me; there wasn’t anything to repair at all.

Not sure what exactly Jesper is suggesting, but I’m not willing reinstall my OS on a hunch. Would take me forever to get everything back in order.

Any other leads so far?

SOLVED this during a previous update that went south.

I’ve found the ‘corruption’ to be somewhere within the User support files or preferences. I didn’t isolate EXACTLY which file but the following firehose approach doesn’t risk losing anything except re-configuring your preferences again.

As the Uninstaller leaves these intact you need to manually delete:

  • ~/Library/Application Support/Total Finder
  • ~/Library/Preferences/com.binaryage.totalfinder.plist [to be thorough you could just search within Library for anything that includes ‘total finder’]

After reinstall all was operating normally again. Just need to go back in to Total Finder preferences and re-customise as desired.

Hope that helps!