TotalFinder Support In macOS 10.14 Mojave

question

#81

I agree. Disabling SIP is bad practice and it an ill judged decision for a developer to ship a product that requires users to do this.


#82

My apologies. The reply was intended for you.

I agree. Disabling SIP is bad practice and it’s an ill judged decision for a developer to ship a product that requires users to do this.


#83

Is it possible you have disabled Apple Mobile File Integrity or Gatekeeper ?

I believe if either are off it will not show the pop up asking for permission to control applications.

The feature also seems to be pretty actively/early in development in the betas as there have been several bugs relating to it that I’ve noticed, so how it is working now isn’t necessarily how it’ll be at release or later builds.


#84

Hi w0lf - so gatekeeper was already set at allow App Store and identified developers, but I made it more permissible and set it to Anywhere. That was unsuccessful.
As for disabling Apple Mobbile File Integrity, I am not familiar with any way to do so. Nor could I find any running activity for amfid in the activity monitor. I do have SIP disabled though.
Thanks

Running macOS D4.


#85

i’m in. :+1:


#86

Please try to follow this gist to inject TotalFinder by hand and report back:


#87

Thanks, manually injecting TotalFinder (1.11.1) worked for me in Mojave 10.14 Beta 7.

EDIT: Well it worked until it crashed (I’ve sent the crash report). I have to run the command again to run TotalFinder. Under Preferences->Security & Privacy->Automation it shows Terminal as having control over Finder instead of TotalFinder. Is there are way to give TotalFinder permission instead of Terminal?

Tried uninstalling and reinstalling. SIP is disabled. Still getting the message “Apple Events cannot be delivered.”. Not getting a prompt for TotalFinder to control Finder.

EDIT2: Okay I managed to get a prompt for TotalFinder to control Finder by installing version 1.10.2. Then I just installed 1.11.1 over the top. So now I have TotalFinder->✓Finder Under Preferences->Security & Privacy->Automation.


#88

Finally started worked with the B7 update!!!

Thank you for all the help; it was most definitely how Mojave handled TotalFinder, having been already installed and not injecting it properly into automation.